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Example – Plate with a hole

E = 210000N/mm2

n = 0.3
a = 200mm
b = 100mm
t = 10mm
r = 10mm
s = 100N/mm2

Objective:
Determine the maximum stress in the x-direction for 
point A and display the deformation figure
Tasks:
Create a submodel to increase the accuracy of the FEA 
without increasing the computational effort significantly?
Topics:
Element type, Real constants, modeling, mapped mesh, 
plot results, output graphics, path operations, 
submodeling

A



Steps in Submodeling

• The process for using submodeling is as 
follows: 
–– Create and analyze the coarse model.Create and analyze the coarse model.
– Create the submodel.
– Perform cut boundary interpolation (CBI).
– Analyze the submodel.
– Verify that the distance between the cut 

boundaries and the stress concentration is 
adequate.
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Example - title
Utility Menu > File > Change Jobname
/jobname, Example0702_coarse Command line entry

GUI

Enter: Example0702_coarse

Utility Menu > File > Change Title
/title, Plate with a hole

Enter: Plate with a hole
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Example – Areas Rectangle
Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions
Create an area given by X=(0,100) and Y=(0,50)

Enter 0 or
leave empty
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Enter 100

Enter 50Enter 0 or
leave emptyPress OK

Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated
(also numbered automatically)



Example – Areas Rectangle
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Example – Areas Circle
Preprocessor > Modeling > Create > Areas > Circle > Solid Circle
Create an area given by (X,Y)=(0, 0) and Radius=10
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Enter 10

Press OK
Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated
(also numbered automatically)



Example - Area
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Example - Operate
Preprocessor > Modeling > Operate > Booleans > Subtract > Areas
Create the final area by subtracting the circular area from the rectangular area

Note: Bottom left corner of ANSYS GUI

Press OK

Select the rectangular area and press OK

Note: Bottom left corner of ANSYS GUI

Select the circular area



Example – Areas
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Example - Numbering

Syllabus 11
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor

Switch on Keypoint, Line, and Area Numbers



Example - List Menu

List Keypoint, Lines, and Areas

Syllabus 12
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor



Example - Plot Menu

Plot Keypoint, Lines, and Areas
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Example – Element Type
Preprocessor > Element Type > Add/Edit/Delete 

Press Add
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Example - Element Type
Preprocessor > Element Type > Add/Edit/Delete 
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Press Options

Press Help to learn more about the
element.

Select Plane strs w/thk



Example – Real Constants
Preprocessor > Real Constants > Add 

Place the cursor
on the relevant
element and
press OK 
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Example - Real Constants
Preprocessor > Real Constants > Add 

Press OK

Press Close
to finish

Enter 10
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Example - Material Properties
Preprocessor > Material Props > Material Models 

Double Click
to step in the
material tree
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Example - Material Properties
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Preprocessor > Material Props > Material Models
Enter 210000
Modulus of elasticity

Enter 0.3
Poisson’s ratio

Click here
to Close

Press OK



Example - Meshing
Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines
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Select/Pick
Lines to
specify
mesh size
for

Pick the two
longest lines

Press OK when finish with selection

See next page



Example – Mesh Size

3 Element subdivisions

5 Element subdivisions

6 Element subdivisions
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Example – Concatenate Lines
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Select L2 and L3 to create 
a topologically four sided 
geometryPress OK



Example - Meshing
Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
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Select individual areas
to be meshed

Select all areas defined
to be meshed

NB: It is often 
necessary to “Clear” 
the model for
example if Element 
Type or model 
geometry is to be 
changed



Example – Mapped Mesh
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Example – Analysis Type

Solution > Analysis Type > New Analysis

File > Write DB log file
Enter “example0702_coarse.lgw”
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Example – Define Loads
Solution > Define Loads > Apply > Structural > Displacement > On Lines

Select UY to fix the plate in the y-direction

Select the 
bottom straight 
line

Press OK
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Example – Define Loads
Solution > Define Loads > Apply > Structural > Displacement > On Lines

Select UX to fix the plate in the x-direction

Select the left 
straight line

Press OK
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Example – Define Loads
Solution > Define Loads > Apply > Structural > Pressure > On lines

Select the 
right 
straight line

Enter -100

Press OK 
to finish
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Note: Pressure acts normal and 
inward to a surface



Example - Save

Display of Analysis model

Save the model
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Example - Solve
Solution > Solve > Current LS
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Press OK



Example - Solve
Press Close

Press here
to Close
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Example – Contour Plot
General Postproc > Plot Results > Contour Plot > Nodal Sol

Select Stress

Select SX for stresses in 
x-direction
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Example – Contour Plot
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Example – Select - Entities

See next page 
for selection
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Example – Select Nodes

Select the 
indicated 
nodes

Enter OK when finished



Example – List Results
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Select Stress, SCOMP

Press OK



Example – List Results
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Example - Plot - Nodes

Plot Nodes

Only 11 FE nodes are 
displayed – the same nodes as 
selected previously
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Example – Select - Entities

Select Pick All
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Example - Plot - Nodes

Plot Nodes
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Example - Plot - Nodes
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Example – Define Path

See next page for selection



Example – Define Path - By Nodes

Syllabus 43
Computational Mechanics, AAU, Esbjerg
AutoDesk InventorEnter OK when finished

Select the 
indicated 
nodes

Note: the 
selection 
order is 
important –
start from the 
hole



Example – Define Path - By Nodes

Enter an appropiate name, e.g. SSX

Enter OK
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Example – Map onto Path

Select Stress, SX

Press OK
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Example – Plot Path on Graph

Select SX

Press OK



Example – Plot Path on Graph
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Steps in Submodeling

• The process for using submodeling is as 
follows: 
– Create and analyze the coarse model.
–– Create the Create the submodelsubmodel..
– Perform cut boundary interpolation (CBI).
– Analyze the submodel.
– Verify that the distance between the cut 

boundaries and the stress concentration is 
adequate.
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Example - title
Utility Menu > File > Change Jobname
/jobname, Example0702_fine Command line entry

GUI

Enter: Example0702_fine

Utility Menu > File > Change Title
/title, Plate with a hole

Enter: Plate with a hole
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Example – Areas Rectangle
Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions
Create an area given by X=(0,25) and Y=(0,25)

Enter 0 or
leave empty
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Enter 25

Enter 25Enter 0 or
leave emptyPress OK

Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated
(also numbered automatically)



Example – Areas Rectangle
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Example – Areas Circle
Preprocessor > Modeling > Create > Areas > Circle > Solid Circle
Create an area given by (X,Y)=(0, 0) and Radius=10
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Enter 10

Press OK
Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated
(also numbered automatically)



Example - Area
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Example - Operate
Preprocessor > Modeling > Operate > Booleans > Subtract > Areas
Create the final area by subtracting the circular area from the rectangular area

Note: Bottom left corner of ANSYS GUI

Press OK

Select the rectangular area and press OK

Note: Bottom left corner of ANSYS GUI

Select the circular area



Example – Areas
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Example - Numbering
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Switch on Keypoint, Line, and Area Numbers



Example - List Menu

List Keypoint, Lines, and Areas
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Example - Plot Menu

Plot Keypoint, Lines, and Areas
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Example – Element Type
Preprocessor > Element Type > Add/Edit/Delete 

Press Add
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Example - Element Type
Preprocessor > Element Type > Add/Edit/Delete 

Press Options

Syllabus 60
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor

Press Help to learn more about the
element.

Select Plane strs w/thk



Example – Real Constants
Preprocessor > Real Constants > Add 

Place the cursor
on the relevant
element and
press OK 
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Example - Real Constants
Preprocessor > Real Constants > Add 

Press OK

Press Close
to finish

Enter 10
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Example - Material Properties
Preprocessor > Material Props > Material Models 

Double Click
to step in the
material tree
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Example - Material Properties
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Preprocessor > Material Props > Material Models
Enter 210000
Modulus of elasticity

Enter 0.3
Poisson’s ratio

Click here
to Close

Press OK



Example - Meshing
Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines
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Select/Pick
Lines to
specify
mesh size
for

Pick the two
longest lines

Press OK when finish with selection

See next page



Example – Mesh Size

6 Element subdivisions

10 Element subdivisions

12 Element subdivisions
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Example – Concatenate Lines
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Select L2 and L3 to create 
a topologically four sided 
geometryPress OK



Example - Meshing
Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
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Select individual areas
to be meshed

Select all areas defined
to be meshed

NB: It is often 
necessary to “Clear” 
the model for
example if Element 
Type or model 
geometry is to be 
changed



Example – Mapped Mesh

Syllabus 69
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor



Example – Define Loads
Solution > Define Loads > Apply > Structural > Displacement > On Lines

Select UY to fix the plate in the y-direction

Select the 
bottom straight 
line

Press OK
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Example – Define Loads
Solution > Define Loads > Apply > Structural > Displacement > On Lines

Select UX to fix the plate in the x-direction

Select the left 
straight line

Press OK
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Example - Submodel
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Example - Steps in Submodeling

• The process for using submodeling is as 
follows: 
– Create and analyze the coarse model.
– Create the submodel.
–– Perform Cut Boundary Interpolation (CBI).Perform Cut Boundary Interpolation (CBI).
– Analyze the submodel.
– Verify that the distance between the cut 

boundaries and the stress concentration is 
adequate.
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Example – CBI Steps

• The following tasks are involved in performing 
the cut boundary interpolation:

1.1. Identify and write the cutIdentify and write the cut--boundary nodesboundary nodes
2. Restore the full set of nodes, write the database to 

Jobname.DB
3. To do the cut boundary interpolation restore the coarse 

model
4. Enter POST1
5. Point to the coarse results file
6. Read in the desired set of data from the results file
7. Initiate cut-boundary interpolation
8. All interpolation work is now done

Syllabus 74
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor



Example – CBI: Step 1

Plot Nodes
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Example – CBI: Step 1

See next page 
for selection
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Example – CBI: Step 1
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Example – CBI: Step 1

Plot Nodes
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Example – CBI: Step 1
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Example – CBI: Step 1

Enter example0702_cutboundaryPress OK



Example - CBI Steps

• The following tasks are involved in performing 
the cut boundary interpolation:

1. Identify and write the cut-boundary nodes
2.2. Restore the full set of nodes, write the database to Restore the full set of nodes, write the database to 

Jobname.DBJobname.DB
3. To do the cut boundary interpolation restore the coarse 

model
4. Enter POST1
5. Point to the coarse results file
6. Read in the desired set of data from the results file
7. Initiate cut-boundary interpolation
8. All interpolation work is now done
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Example – CBI: Step 2

Select Pick All
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Example - CBI Steps

• The following tasks are involved in performing 
the cut boundary interpolation:

1. Identify and write the cut-boundary nodes
2. Restore the full set of nodes, write the database to 

Jobname.DB
3.3. To do the cut boundary interpolation restore the To do the cut boundary interpolation restore the 

coarse modelcoarse model
4. Enter POST1
5. Point to the coarse results file
6. Read in the desired set of data from the results file
7. Initiate cut-boundary interpolation
8. All interpolation work is now done
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Example – CBI: Step 3
Enter example0702_coarse.db

Press OK
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Example – CBI: Step 3
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Example - CBI Steps

• The following tasks are involved in performing 
the cut boundary interpolation:

1. Identify and write the cut-boundary nodes
2. Restore the full set of nodes, write the database to 

Jobname.DB
3. To do the cut boundary interpolation restore the coarse 

model
4.4. Enter POST1Enter POST1
5.5. Point to the coarse results filePoint to the coarse results file
6.6. Read in the desired set of data from the results fileRead in the desired set of data from the results file
7. Initiate cut-boundary interpolation
8. All interpolation work is now done
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Example – CBI: Step 4-6

Browse to find the result file 
see next page

Select All items



Example – CBI: Step 4-6
Read the First Set

Enter example0702_coarse.rst
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Example - CBI Steps

• The following tasks are involved in performing 
the cut boundary interpolation:

1. Identify and write the cut-boundary nodes
2. Restore the full set of nodes, write the database to 

Jobname.DB
3. To do the cut boundary interpolation restore the coarse 

model
4. Enter POST1
5. Point to the coarse results file
6. Read in the desired set of data from the results file
7.7. Initiate cutInitiate cut--boundary interpolationboundary interpolation
8. All interpolation work is now done
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Example – CBI: Step 7
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Press OK Browse to find 
example0702_cutboundary



Example – CBI: Step 7

Press OKEnter example0702_fine.db
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Example – CBI: Step 7

Load the example0702_fine.cbdo
Press OK
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Example – CBI: Step 8
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Example - Solve
Press Close

Press here
to Close
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Example – Contour Plot
General Postproc > Plot Results > Contour Plot > Nodal Sol

Select Stress

Select SX for stresses in 
x-direction
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Example – Contour Plot

Syllabus 96
Computational Mechanics, AAU, Esbjerg
AutoDesk Inventor



Example – Select - Entities

See next page 
for selection
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Example – Select Nodes

Select the 
indicated 
nodes
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Example – List Results
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Select Stress, SCOMP

Press OK



Example – List Results
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Example - Plot - Nodes

Plot Nodes

Only 21 FE nodes are 
displayed – the same nodes as 
selected previously
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Example – Select - Entities

Select Pick All
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Example - Plot - Nodes

Plot Nodes
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Example - Plot - Nodes
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Example – Define Path

See next page for selection



Example – Define Path - By Nodes

Select the 
indicated 
nodes

Note: the 
selection 
order is 
important –
start from the 
hole
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Example – Define Path - By Nodes

Enter an appropiate name, e.g. SSX

Enter OK
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Example – Map onto Path

Select Stress, SX

Press OK
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Example – Plot Path on Graph

Select SX

Press OK



Example – Plot Path on Graph
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File menu
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Clears (zeros out) the database stored in 
memory. Clearing the database has the same 
effect as leaving and reentering the ANSYS 
program, but does not require you to exit. 

You can include commands to be 
executed when the program starts up in 
the start71.ans file. 
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