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Example — Turbine Blade
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Example — Turbine Blade

* Objective: Solve for the

temperature distribution E = 210000N/mm"
within the 6mm thick V=03 .
turbine blade. with 2mm x Thermal conductivity of blade
! . = 25W/(m-K)
6mm reCtangUIar COO“ng Operating conditions:
channels. T,, = 1700K
« Tasks: How should this 1o = 1000/ (m™K)
4i
be modelled? "2 200W/(m-K)
 Topics: Element type, A =6mm
thermal analysis, B =4mm
modeling, plot results € =2mm
’ ’ D = 6mm

output graphics
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0601 ¢ Command line entry
x| Enter: Example0601

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Temperature in a Turbine Blade
[title, Temperature in a Turbine Blade
x|
[/TITLE] Enter new title || °
0] Cancel Help
ANSYS Example0601 4
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Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS

I\ Create Keypoints in Active Coordinate System x|
[K] Create Keypoints in Active Coordinate Systern

NPT Keypoint number I

¥,Y,Z Location in active CS | | | o—‘

0K | Anply | Cancel | Help | Enter the KP’s

Keypoint Number X-Location Y-Location
1 -0.005 0.003
2 0 0.003
3 0 0.001
4 -0.003 0.001
5 -0.003 0
6 -0.005 0
ANSYS Example0601
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line

Create Straig HINT: By clicking with the right-
@ Pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
S O arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc
Press OK or Cancel
to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help
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Example - Lines

' ANSYS

POINTS
MAR 17 2004
10:16:15

T¥FE NUM
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Example - Areas

Preprocessor > Modeling > Create > Areas > Arbitrary > By Lines
Create an area bounded by line 1, 2, 3, and 4.

AL,1,2,3,4
HINT: By clicking with the right-
P hand mouse button you shift

between the Pick/Unpick

v Single { Eox

N functl_on. Thls IS indicated by
" Loop the direction of the cursor
Count = 0 arrOW:

Maximum = 4

St Pick: upward arrow

Line Mo.

Unpick: downward arrow

{* List of Items

i Min, Max, Inc

Press OK or Cancel
! to finish selection

0K @ gk

Leset Cancel |@

/ Piglk ALL Help Examp|60601
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Example — Areas Rectangle

1
POINTS

TYPE NUM
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
l\Library of Element Types x|
Defined Element Types: ] —
Library of Element Types Combination -
Thermal Mass Brode 77
Lirk Triangl 6hode 35
Axi-har 4node 75
Shell Bnode 73 -
AMNSYS Fluid
FLOTRAN CFD » || Quad 4node 55

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptions: Belete Press Add
Clase | Help |
ANSYS Example0601 10
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types

Defined Element Types:

PLAMESS

i PLANESS element type options |

|

Options for PLAKWESS, Element Type Ref, Mo, 1

Evaluate film coefficient at K1

Element behavior K3 ||:-| = d

Elerment caord system defined K4 Ipara” to global j
Mass transport effects K8 IEHEl mass fransp d
Monlinear fiuid flow option K9 Igm heat transf j

(0] 4 | Cancel | Hzlp @

add... Dptions. .. | [ Belate

Cloze | Help |

Press Options

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0601 12
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter 210000 |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter 0.3
S S Poisson’s ratio
Temperatures
EX
PRXY ] 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0601
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Example - Material Properties

Preprocessor > Material Props > Material Models Double Click
to step in the
[\ Define Material Model Behavior Ol x| material tree
wWaterial  Edit Help
— Material Models Defined — Material Models Available
& Material Model Nurmber 1 ] Structural 2
@@ Thermal
#B Conductivity
@ [=ofropiclg
€ Orthotropic
@ Specific Heat Conductivity for Material Number 1 X|
& Density
@ Enthalpy Conductivity (Isotropic) for Material Number 1
& Emissivity
€ Corvection or Film Coe T1
= € Heat Generation Rate | Temperaiires I—
< e oo
Add Termperature | Delete Temperature | Graph
] Cancel Help
ANSYS Example0601 14
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Example - Material Properties

Preprocessor > Material Props > Material Models

Conductivity for Material Number 1

Conductivity (Isotropic) for Material Number 1

R

i

Temperatures I
I

I\ Define Material Model Behavior

Enter 25

Thermal conductivity

add Temperature | Delete Temperature |

]9 |

Cant

Press OK —

ANSYS

Material  Edit Helg

— Material Models Defined

£ Material Model Nurnber 1

o

— Material Models Available

Click here

to Close

=10l x|

Structural
@ Thermal
@8 Conductivity
@ [sofropic
€ Orthotropic
€ Specific Heat
£ Density
€ Enthalpy
£ Emissivity
£ Corvection or Film Coef,
£ Heat Gereration Rate

[ M=
d

Example0601
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size Element Sizes on Picked Lines X|

I o i [LESIZE] Element sizes on picked lines

SIFE Element edge length I
(o Single " Box I_

W el ey e MDY  Mo. of element divisions o
" Loop (MDIV is used only if SIZE is blank or zero)
KYNDIV SIZE,NDIV can be changed v Yes
Colt = 0
. . _ SPACE Spacing ratio I
Select/Pick meximam =1
; ndman = 4 ANGSIZ Division arc (degrees) I
LlneS tO Line MNo. = <
; ANGSIZ only if number of divisions (NDIV) and
Speci o
p hfy {* Lizt of Items element edge length (SIZE) are blank or zerao) See next page
mesn Size
f " Min, Max, Inc Clear attached areas and volumes [T Mo
or

Pick the two e —— oK | Apply | Cancel | Help |

longest lines

Beset Cancel

Pick &1l Help

Press OK when finish with selection

ANSYS Example0601 16
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Example - Lines

il

POINTS

T¥FE NUM

5 Element subdivisions

ANSYS

MAR 17 2004
10:16:15

Jd

I
°
2 Element subdivisions
3 Element subdivisions

1 Element subdivisions

4

2 Element subdivisions 3 Element subdivisions —

ANSYS

Example0601
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Example — Free Meshing

Preprocessor > Meshing > Mesh > Areas > Free

Computational Mechanics, AAU, Esbjerg

ANSYS Main Menu ANSYS Main Menu @'
Preferences Preferences 1=
B Preprocessor B Preprocessor
Element Type Element Type
H Real Constants ® Real Constants
Material Props Material Props
Sections Sections
Modeling Modeling
= Meshing =2 Meshing
Mesh Attributes Mesh Attributes
MeshTool MeshTool
Size Cntrls Size Cntrls
Mesher Opts Mesher Opts
Concatenate Concatenate
B Mesh B Mesh
# Keypoints A Keypoints
& Lines A Lines
ERAIreas| E Areas
Mapped Mapped
& Free #
#1 Target Surf #1 Target Surf
Volumes Yolumes
Yolume Sweep Yolume Sweep
Tet Mesh From Tet Mesh From
Interface Mesh Interface Mesh L
Modify Mesh Modify Mesh
Check Mesh Check Mesh
Clear Clear
Checking Ctrls Checking Ctris
Numbering Ctrls Numbering Ctrls
Archive Model Archive Model
Coupling / Ceqgn Coupling / Ceqgn
FLOTRAN Set Up FLOTRAN Set Up
FSI Set Up FSI Set Up
Loads Loads j
4| <] [
ANSYS

Mesh Areas

% pick @ fpick

[ Bingle " Box

" Polygon {" Circle

- Loop

Count = a
Maximam =
Minjmam = 1
Area Mo. =

¥ List of Items

- Min, Max, Inc

0K Apply
Ba=set Cancel
Pick A11 Heln
L J

Select individual areas
to be meshed

NB: It is often
necessary to “Clear”
the model for
example if Element
Type or model
geometry is to be
changed

Select all areas defined
to be meshed

Example0601
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Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0601.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0601 19
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Apply CONY

Example — Define Loads

Solution > Define Loads > Apply > Thermal > Convection > On Lines

I Apply CONV on lines

[SFL] Apply Film Coef on lines

@ pick @ tmpick

Select the top
horizontal line
L1

Constant vallue

If Constant value then:
YaLl o Film coefficient

I'

i+ Bingle i~ Box |
A Enter 1000 _
= e " Circle [SFL] &pply Bulk Temp on lines Canstant value j
Loop
If Constant value then:
Cons WAL2T Bulk temperature | II ®
Maximuam = &
Minimm = 1 Enter 1700 If Comstant value then:
bia LS = Optional COMY values at end 1 of line
_ {leave blank for uniform COMY )
Sl e VALl Film coefficient |
- Min, Max, Inc
Yalzl  Bulk temperature I
f
0E @ PN o
Reset Cancel
Pidk ALl — Ok @ | Apply Cancel Help |
Press OK '
ANSYS Example0601 20
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Example — Define Loads

Solution > Define Loads > Apply > Thermal > Convection > On Lines

Select the I\ Apply CONV on lines X1
Apply CONV lines L3 and [SFL] Apply Film Coef on lines Constant value
@ pick @—tmpick L4 If Constant value then:
YALTD  Film coefficient |.
i+ Bingle i~ Box | |
Enter 200
" Polygon (" girele [SFL] &pply Bulk Temp on lines Canstant value j
i Loop
If Constant value then:
Cons WALZT Bulk temperaUJre| IIO
Maxi = &
o Enter 400
Minimm = 1 If Comstant value then:
bia LS = Optional COMY values at end 1 of line
_ {leave blank for uniform COMY )
Sl e VALl Film coefficient |
ri i
R Yalzl  Bulk termperature I
f
0E @ PN o
Reset Cancel
Pidk ALl — (04 T | Apply Cancel Help
Press OK
ANSYS Example0601 21
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Apply HFLUX

Example — Define Loads

Solution > Define Loads > Apply > Thermal > Heat Flux > On Lines

@ pick @ tmpick

i+ Bingle

" Pa lvrgorn

i Loop

{ Box

{" Circle

Count
Maximuam
Minjimuam

Line No.

{¥ List of Items

- Min, Max, Inc

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Select the
lines L6, L2
and LS X
[SFL] Apply HFLUX on lines as a ICDnstant - d
If Constant value then:
VAL Heat flux I
Optional HFLU values at end J of line
{leave blank for uniform HFELUX
Yall Heat flux I
oK @ | Apply | Cancel | Help |
By default, this will specify a
heat flux of zero along these
three lines, which is consistent
with the symmetry of the
Press OK problem.
Example0601 22
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Example - Save

il
LINES

LINE HNUM

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

!

ANSYS Example0601 23
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0601
Computational Mechanics, AAU, Esbjerg




Example - Solve

Press Close

_ i ) Solution is done!

Press here
to Close
: y
I\ /STATUS Command L X|
File
I
SOLUTION OPTIONS

PROELEH DIMERSIOMALITY. « « v v v v v o v v o . 2

OEGREES OF FREEDOM. . . . . . TERP

BHALYSIS TYPE » v o v v e e e e e e e e e a STRTIC (STEADY-STRTE)

LOAD STEP OFPTIONS

LOAD STEP HUHBER. » » v o v v e e v e e e n s 1

TIHE AT END OF THE LORD STEP. . .+ o o o o . 1.0000

HUNEER OF SUBSTEPS. . v« v v v v v v e v v o 1

STEP CHANGE BOUNDARY CONDITIONS . . . . . . . . H

PRINT OUTPUT CONTROLS .+ « .« v v v oo s o o s KO PRINTOUT

ORTRBASE DUTPUT CONTROLS. &+ o v v s o e s o s ALL DATA WRITTEN

FOR THE LAST SUBSTEP
ANSYS Example0601 25
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Example — Contour Plot

General Postproc > Plot Results > Contour Plot > Nodal Sol

fil Contour Nodal Solution Data | x| .
[PLNSOL] Contour Nodal Solution Data l Select DOF solution

Item,Comp  Itermn to be contoured

Flux & gradient
Contact

Temperature TEWMP

KUMD  Items to be plotted
&+ Def shape only
" Def + undeformed

" Def + undef edge
[/EFACET] Interpolation Modes

& Carner only
" Carner + midside

" all applicable

ok | Apply | Cancel | Help |

ANSYS Example0601
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Example — Contour Plot

NODAL SOLUTIOHN

3TEP=1
SUB =1
TIME=1
TEMFE

R3¥E=0

ANSYS Example0601
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit... Example0601
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