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Example — Temperature in a plate
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Objective:

Solve for the temperature distribution within
the rectangular plate, based on the
specified temperatures on the plate edges,
and the plate dimensions.

Tasks:

How should this be modelled?

Topics:

Element type, thermal analysis, modeling,
plot results, output graphics

E = 210000N/mm®

v=0.3

Thermal conductivity = 401W/(m-K)

a=10m

b =20m
T1=100C
T2 =100C
T3 =200C
T4 =100C
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0600 Command line entry
| Enter: Example0600

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Temperature in a plate
[title, Temperature in a plate
x|
[/TITLE] Enter new title || °
0] Cancel Help
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Example — Areas Rectangle

Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions

AMNSYS Main Menu @' Enter O or
'references 1=l
'reprocessor Ieave em pty
H Element Type . .
1 Real Constants I\ Create Rectangle by Dimensions |
H Material Props
# Sections [RECTMG] Create Rectangle by Dirmensions Enter 10
F gugg:]t% ¥1,%2 ¥-coordinates I ® I
Keypoints .
Lines v1,¥2 Y-coordinates I °® I

B Areas
Arbitrary

B Rectangle
& By 2 Corners ok, OJ Apply | iZancel | Help |
& By Centr & Cornr 9

By Dimensions
H Circle
_F‘?E’E‘E’.}et Enter O or Enter 20
2 —— Press OK leave empty

Contact Pair
Piping Models
Circuit
Racetrack Coil

BT T Note: Keypoints (4 kp’s) and lines
perate

Move ; Modify (4 lines) are automatically generated
e (also numbered automatically)
Check Geom
Delete

Cyclic Sector

5 R |,|j Example0600 4
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Example — Areas Rectangle

il

AREAS

TYPE NUM
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
l\Library of Element Types x|
Defined Element Types: ] —
Library of Element Types Combination -
Thermal Mass Brode 77
Lirk Triangl 6hode 35
Axi-har 4node 75
Shell Bnode 73 -
AMNSYS Fluid
FLOTRAN CFD » || Quad 4node 55

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptians: Selete Press Add
Clase | Help |
ANSYS Example0600 6
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types

Defined Element Types:

PLAMESS

i PLANESS element type options |

|

Options for PLAKWESS, Element Type Ref, Mo, 1

Evaluate film coefficient at K1

Element behavior K3 ||:-| = d

Elerment caord system defined K4 Ipara” to global j
Mass transport effects K8 IEHEl mass fransp d
Monlinear fiuid flow option K9 Igm heat transf j

(0] 4 | Cancel | Hzlp @

add... Dptions. .. | [ Belate

Cloze | Help |

Press Options

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg

element.
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

& Material Model Nurmber 1

Double Click

ANSYS

=[0] x| :
to step in the
— Material Models Available mate”al tree
|| @@ structural ]
@ Linear
8 Elastic

@ [sofropicll g

€ Orthotropic

@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -

| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
|;|_‘ 1 EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
Example0600 8
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter 210000 |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter 0.3
B Poisson’s ratio
Temperatures
EX
PRICY =10] x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0600
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Example - Material Properties

Preprocessor > Material Props > Material Models Double Click
to step in the
[\ Define Material Model Behavior Ol x| material tree
wWaterial  Edit Help
— Material Models Defined — Material Models Available
& Material Model Nurmber 1 ] Structural 2
@@ Thermal
#B Conductivity
@ [=ofropiclg
€ Orthotropic
@ Specific Heat Conductivity for Material Number 1 X|
& Density
@ Enthalpy Conductivity (Isotropic) for Material Number 1
& Emissivity
€ Corvection or Film Coe T1
= € Heat Generation Rate | Temperaiires I—
< e oo
Add Termperature | Delete Temperature | Graph
] Cancel Help
ANSYS Example0600 10
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Example - Material Properties

Preprocessor > Material Props > Material Models

Conductivity for Material Number 1

Conductivity (Isotropic) for Material Number 1

R

i

Temperatures I
I

I\ Define Material Model Behavior

Enter 401
Thermal conductivity

add Temperature | Delete Temperature |

]9 |

Cant

Press OK —

ANSYS

Material  Edit Helg

— Material Models Defined

£ Material Model Nurnber 1

o

— Material Models Available

Click here

to Close

=10l x|

Structural
@ Thermal
@8 Conductivity
@ [sofropic
€ Orthotropic
€ Specific Heat
£ Density
€ Enthalpy
£ Emissivity
£ Corvection or Film Coef,
£ Heat Gereration Rate

[ M=
d

Example0600
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size Element Sizes on Picked Lines X|

I o i [LESIZE] Element sizes on picked lines

SIFE Element edge length I
(o Single " Box I_

W el ey e MDY  Mo. of element divisions o
" Loop (MDIV is used only if SIZE is blank or zero)
KYNDIV SIZE,NDIV can be changed v Yes
Colt = 0
. . _ SPACE Spacing ratio I
Select/Pick meximam =1
; ndman = 4 ANGSIZ Division arc (degrees) I
LlneS tO Line MNo. = <
; ANGSIZ only if number of divisions (NDIV) and
Speci o
p hfy {* Lizt of Items element edge length (SIZE) are blank or zerao) See next page
mesn Size
f " Min, Max, Inc Clear attached areas and volumes [T Mo
or

Pick the two e —— oK | Apply | Cancel | Help |

longest lines

Beset Cancel

Pick &1l Help

Press OK when finish with selection

ANSYS Example0600 12
Computational Mechanics, AAU, Esbjerg




Example - Meshing

Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
®| |
Select individual areas

AMNSYS Main Menu ANSYS Main Menu AMNSYS Main Menu

Preferences
E Preprocessor

Preferences
E Preprocessor

Preferences
B Preprocessor

Element Type Element Type Element Type _
Real Constants Real Constants Real Constants * pick@——tmpick to be meshed
Material Props Material Props Material Props
Sectiu_ns Sectiu_ns Sectiu_ns * Single e
Modeling Modeling Modeling
E Meshing B Meshing B Meshing " Tolygonm ¢ Cirele
Mesh Attribute: Mesh Attributes Mesh Attributes . )
MeshTool MeshTool MeshTool N B . It IS Often
Size Cntrls Size Cntrls Size Cntrls '
Mesher Opts Mesher Dpts Mesher Opts Count = 0 0 n
Concatenate Concatenate Concatenate Maximum = 1 necessary to Clear
B Mesh B Mesh 2 Mesh
# Keypoints A Keypoints A Keypoints Minimum = 1 the mOdel for
& Lines A Lines # Lines .
Area No. =
o 8 Areas 5 Areas el example if Element
Mapped =i B Mapped
2 Free #1 By Corners 21 By Corners Ol hen Gf Tetme Type or mOdeI
#1 Target Sur 213 or 4 sided P2
Volumes Concatenate Concatenate

Yolume Swee

Tet Mesh Fro

Interface Me:
Modify Mesh
Check Mesh
Clear

Del Concats
& Free
A Target Surf
Yolumes
Volume Sweep
Tet Mesh From

Del Concats

# Free

- Min, Max, Inc

A Target Surf ||

Yolumes
Yolume Sweep
Tet Mesh From

Computational Mechanics, AAU, Esbjerg

geometry is to be
changed

Select all areas defined
to be meshed

Checking Ctrls Interface Mesh Interface Mesh 0E Apply
Numbering Ctrls Modify Mesh Modify Mesh
Archive Model Check Mesh Check Mesh Deset CaaeD
Coupling / Ceqgn Clear Clear
FLOTRAN Set Up Checking Ctrls Checking Ctrls i
F5I Set Up Numbering Ctrls Numbering Ctrls Pl‘:k.‘a‘ll Help
Loads Archive Model Archive Model j
| | [ |+
ANSYS Example0600
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Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0600.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0600 14
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Example — Define Loads

Solution > Define Loads > Apply > Thermal > Temperature > On Lines

Apply TEMP o

% pick @& —mpick

i+ Bingle i~ EBojk

" Polygon {" Circle
i Loop

I
]

Count
Maximuam

Minjimuam

[} ] n
=~

Line No.

{¥ List of Items

- Min, Max, Inc

Select the two
vertical lines

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

Enter 100

I\ Apply TEMP on lines I X
[OL] Apply TEMP on lines as a ICDnstant vlle j
If Constant value then:
WALUE Load TEMP value || 'Y
Apply TEMP 1o endpaints? W ey @——————
oK @ Aoy | Cancel | Help

—— Press OK Setto No —

Example0600 15




Solution > Define Loads > Apply > Thermal > Temperature > On Lines

Example — Define Loads

Apply TEMP

% pick @& —mpick

i+ Bingle
i Polygon
i Loop

{" Bok

" Cipcle

Count
Maximuam

Minjimuam

Line No.

{¥ List of Items

- Min, Max, Inc

Select the
bottom
horizontal line

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

Enter 100

I\ Apply TEMP on lines _ X|
[OL] Apply TEMP on lines as a ICDnstant vlle j
If Constant value then:
VALUE Load TEMP value I °
Apply TEMP to endpoints? Iv ‘fes
oK @ apply | Cancel | Help |
——— Press OK Setto Yes —
Example0600 16




Example — Define Loads

Solution > Define Loads > Apply > Thermal > Temperature > On Lines

Apply TEMP o

% pick @& —mpick

i+ Bingle i~ EBojk

" Polygon {" Circle
i Loop

I
]

Count
Maximuam

Minjimuam

[} ] n
=~

Line No.

{¥ List of Items

- Min, Max, Inc

Select the top
horizontal line

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

Enter 200

I\ Apply TEMP on lines I X
[OL] Apply TEMP on lines as a ICDnstant vlle j
If Constant value then:
WALUE Load TEMP value || 'Y
Apply TEMP 1o endpaints? W ey @——————
oK @ Aoy | Cancel | Help

—— Press OK Setto No —

Example0600 17




Example — Define Loads

Solution > Define Loads > Apply > Thermal > Temperature > On Lines

Apply TEMP

% pick @& —mpick

i+ Bingle i~ EBojk

" Polygon " Cipcle

[ Lo

I
]

Count
Maximuam

Minjimuam

[} ] n
=~

EeyP Mo

{¥ List of Items

- Min, Max, Inc

Select the two
top corner
points

Enter 150

I\ Apply TEMP on kpnts
[Dk] Apply TEMP on kpnts as a

i_onstant v

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

If Constant value then:
YALUE Load TEMP value

KEXPND Expand TEMP to nodes?

oK @ Apply |

Cancel | Helpn

— Press OK

Example0600

Setto No —
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Example - Save

. ANSYS

MAR 17 2004
09:11:13

ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model
SoavVE_DB | RESLIM_DB ‘ QUIT | POVYRGEPH ‘ E-CAE |

!

ANSYS Example0600 19
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

b Example0600
Computational Mechanics, AAU, Esbjerg




Example - Solve

Press Close

_ i ) Solution is done!

Press here
to Close
: y
I\ /STATUS Command L X|
File
I
SOLUTION OPTIONS

PROELEH DIMERSIOMALITY. « « v v v v v o v v o . 2

OEGREES OF FREEDOM. . . . . . TERP

BHALYSIS TYPE » v o v v e e e e e e e e e a STRTIC (STEADY-STRTE)

LOAD STEP OFPTIONS

LOAD STEP HUHBER. » » v o v v e e v e e e n s 1

TIHE AT END OF THE LORD STEP. . .+ o o o o . 1.0000

HUNEER OF SUBSTEPS. . v« v v v v v v e v v o 1

STEP CHANGE BOUNDARY CONDITIONS . . . . . . . . H

PRINT OUTPUT CONTROLS .+ « .« v v v oo s o o s KO PRINTOUT

ORTRBASE DUTPUT CONTROLS. &+ o v v s o e s o s ALL DATA WRITTEN

FOR THE LAST SUBSTEP
ANSYS Example0600 21

Computational Mechanics, AAU, Esbjerg



Example — Contour Plot

General Postproc > Plot Results > Contour Plot > Nodal Sol

fil Contour Nodal Solution Data | x| .
[PLNSOL] Contour Nodal Solution Data l Select DOF solution

Item,Comp  Itermn to be contoured

Flux & gradient
Contact

Temperature TEWMP

KUMD  Items to be plotted
&+ Def shape only
" Def + undeformed

" Def + undef edge
[/EFACET] Interpolation Modes

& Carner only
" Carner + midside

" all applicable

ok | Apply | Cancel | Help |

ANSYS Example0600
Computational Mechanics, AAU, Esbjerg



Example — Contour Plot

ANSYS

MAR 17 2004
09:30:08

NODAT, SCOLUTICON

STEP=1

SUB =1

TIME=1

TEME AV
RSTS=0

SMN =100

3ME =200

L

122,222 144,444 166,667 188.889
111.111 133.333 155.556 177.778 200

ANSYS Example0600
Computational Mechanics, AAU, Esbjerg




Example - Plot - Nodes

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help

Replot |

Keyvpoints k keypoints
Lines Hard Paints
Areas

Yolumes

Specified Entities 4

Modes @
Elements
Layered Elements ...

Plot Nodes

Materials
Data Tables
Array Parameters L.,

Results 4
multi-Plots
Components 4
Farts

ANSYS Example0600
Computational Mechanics, AAU, Esbjerg
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Example — Select - Entities

File Select List Plot PlotCirls

Select Ent X|

Entities ...

Comp/assembly

Parts ..,

-

WiorkPlane Parameters

Macro  MenuChrls

Everything

Everything Below

-

ANSYS

INudt:s j

|By NumyPick ~|

* From Full
" Reselect

" Also Select

" Unselect

Sele All | Invert |
Sele Nunel Sele Eelul

—=e 0K | Apply |
Plot | Flf:plut|
Can[:t:l| Help |

Select nodes

{* pick @ ' THRpIcE

v Single {~ Box

" Polygon " Circle
[ Loop

&

Count

Maximuam 4z
Minjmum = 1

Node Mo. 10

{¥ List of Items

- Min, Max, Inc

0K Apply
Reset Cancel
Pick A1l Help

Example0600

Computational Mechanics, AAU, Esbjerg

See next page
for selection
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Example — Select Nodes

Select node

{* pick " Tmpick

{* zingle {" Box

" Polygon (= Circle
~

Count = &
Maximum = 4z
Minjmum = 1 Select the
e indicated
{* List of Items nOdeS
(" Min, Max, Inc
® o Apply
Beset Cancel
ick All L
ANS¥S— Enter OK when finished ~ Example0600 26
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Example — List Results

AMSYS Main Menu

@|

Preferences
Preprocessor
Solution
E General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
Plot Results
B List Results
Detailed Summar:
Iteration Summry
Percent Error
Sorted Listing
Element Solution
Section Solution
Superelem DOF
Reaction Solu
Nodal Loads
Elem Table Data
vector Data
Path Items
Linearized Strs
Ouery Results
Options for Outp
Results Yiewer
Write PGR File
mModal Calcs
Element Table
Path Operations
Load Case

[ |

-

ANSYS

F\List Nodal Solution 1

[FEMSCL] List Modal Solution

Item,Comp  Iem o be listed

Flux & gradient
MNonlinear items

Cancel |

Computational Mechanics, AAU, Esbjerg

Select DOF solution, TEMP

— Press OK

Example0600

Temperature TEMP ®
Temperature TEMP
Help |
27



Example — List Results

FA\PRNSOL  Command {

Fil=

|
PRINT TEHP MODAL SOLUTION PER HOOE
sk POST] WOOAL DEGREE OF FREEDOH LISTING e

LOAD STEP= 1 SUBSTEP= 1
TIHE=  1.0000 LOAD CRSE= O

HODE TERP
7 100.00
11 100.00
14 113.48
16 113.48

HAX IHUN ABSOLUTE MALLES
HODE 14
YALUE  113.48

ANSYS Example0600
Computational Mechanics, AAU, Esbjerg



Example — Select - Entities

File Select List Plot PlotCirls

Entities ...
Comp/assembly
Parts ...

-

WiorkPlane Parameters

Everything
Everything Below

-

ANSYS

f\select Ent X|
INudt:s j

|By NumyPick ~|

* From Full
" Reselect

" Also Select

" Unselect

Sele All | Invert |
Sele Nunel Sele Eelul

—=e 0K | Apply |
Plot | Flf:plut|
Can[:t:l| Help |

Macro MenuCtrls Help
Select nodes
{* pick - Tnpick
v Single {~ Box
" Polygon " Circle
[ Loop
Count = =
Maximum = 4z
Minjmum = 1
Node Mo. = 10 |
Select Pick All

{¥ List of Items

- Min, Max, Inc

(1].4

Apply

Reset

Cancel

Pick All*—Hrl-p—

Example0600

Computational Mechanics, AAU, Esbjerg
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit... Example0600

Computational Mechanics, AAU, Esbjerg
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