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Example — Frame 2D

Objective:
y Compute the harmonic response
X Tasks:
Perform a modal analysis
ool Display the mode shapes
= Perform a harmonic analysis
i\\ b} Top_ics: |
i a Topics: Start of analysis, Element type,
o Real constants, Material, modeling, ele-
ment size for beam models, modal and
harmonic analysis

X E = 200E9N/m?
v =0.3
L _ L =2m
' H=3m
| =0.14/12m*
0 = 7860kg/m3
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0410 ¢ Command line entry
x| Enter: Example0410

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Frame 2D
ftitle, Frame 2D
x|
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0410 3
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Example - Parameters

File Select List Plot PlotCirls

WiorkPlane Parameters

Scalar Parameters

[tems

Scalar Parameters ...
Get Scalar Data ...

Array Pararmeters
Get Array Data
Array Operations

Functions

(R
=
=
=
=
=
=
=
=
=
m
+
-
—_

Selection

Angular Units

Save Parameters
Festore Farameters

[=1e-4/12

Accept Delete Cloze

Help |

ANSYS
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY G | £ . # Keypoint number
K,s, eneralformat. % Keypoint x-coordinate
K,,,3, K#,X,Y,Z Y Keypoint y-coordinate
K 23 Z Keypoint z-coordinate
Enter 0,0,0 and
Press Apply
Enter 0,3,0 and
Press Apply
Enter 2,3,0 and
Press Apply
I\ Create Keypoints in Active Coordinate Systen x|
[K] Create Keypaints in Active Coordinate System
NPT  Keypoint number l—
¥,%,Z Location in active CS | P i i
Note: An empty box
e L result in a zero. It is
ook | ooy | e [ i allowed to enter 0.0
in each box.
ANSYS Example0410 5
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Example - Numbering

Utility Menu > PlotCtrls > Numbering Switch on Keypoint numbers
Fan Zoom RFotate ...
View Settings b Fi\Plot Numbering Controls |
Numbering ... [/FNUM] Plot Numbering Controls
Symhbals .. KF  Keypoint numbers ¥ on
Style ?
LIME Line numbers [ off
Fomt Contrals »
Window Controls » AREA  Area numbers [ off
Erase Options >
YOLU Valume numbers [C off
Animate 4
e , MOCDE Mode numbers [ off
Device Options .. R Elem / attrib numbering INI:I numbering j
Redirect Plots i TA4BN Table Marmes I~ off
Hard Copy 4
R SWAL Mumeric contour values [~ off
G P g [MUM] Mumbering shown with ICDIDrs & numbers j
Reset Plot Cirls

=
Capture Image .. [/REPLOT] Replot upon Ok Aapply: IREpl':'t j

Festore Image ...

Write Metafile * (]34 QJ Apply | Cancel | Help |

Multi-Flot Controls .. Press OK

ML lt-vindowr Layout ...

/ Best Quality Image r Example0410 6
Computational Mechanics, AAU, Esbjerg



Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between KP1 and KP2 and KP2 and KP3.

L,1,2
L.2,3 Create Straig HINT: By clicking with the right-
® pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
. the direction of the cursor
Maximm = 2 arrow:
B
e . - Pick: upward arrow
Fo Unpick: downward arrow
{" Min, Max, Inc
Press OK or Cancel
to finish selection
IE @ Epprty
Deset Cancel@®
Piglk ALl Heln
ANSYS Example0410
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Example - Plot - Nodes

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help

Replot |

Keypoints @ ——Feypoints
Lines Hard Points

Areas

volumes — Plot Keypoints and Lines
Specified Entities 4

MNodes
Elements
Layered Elements ...

Materials
Data Tables
Array Parameters L.,

Results +
mLlti-Plots
Components 4
Parts
ANSYS Example0410
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
Defined Element Types: ml‘lbrar? of Element Types x|
Library of Element Types SR UEHIEa MSes
Lirk plastic 23
tapered 54
Fipe 30 finite strain
Rigid 2 node 188 -
Solid
Shell ;I 2D elastic 3

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptions- Selete Press Add
Clase | Help |
ANSYS Example0410 9
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

x|

Add... Options... |0 Belete

IBEAMS element type options ]

Cptions for BEAMS, Element Type Ref, Mo, 1

Member force + mament output K&

Output at extra intermed pts K9 IN.;. inter med pts j

Load offset in terms of K10

Ik |

ILengﬂﬂ Lnits j

Cancel | Help |0

Close |

Press Options

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg

element.
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 BEAMI

Place the cursor
on the relevant
element and
press OK

[ L= =]

Example0410
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Example - Real Constants

Preprocessor > Real Constants > Add

Real Constants

l\Real Constants for BEAMS Defined Real Constant Sets

Element Type Reference Mo, 1
Real Constant Set Mo,

Enter cross
sectional data

“E

Cross-gectional area AREA H*h

L

Area moment of inertia 77 I

Total beam height HEIGHT

Shear deflection constant SHEARZ

Initial strain ISTEM

1y

Added mass/unit length  ADDMAS

oK Apply Cancel | Help | Edit... | Delete |
®
Press Close
to f|n|Sh Close @ Heln |
Press OK
ANSYS Example0410 12
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0410 13
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter E |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter nu
B Poisson’s ratio
Temperatures
EX
PRXY ] 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0410
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Example - Density

Ii\Define Material Model Behavior l - 0] x|
rMaterial  Edit Help

— Material Models Defined — Material Models Available Enter 7830
£ Material Model Nurmber 1 [ @ Structural ﬂ
Linear
Monlinear

Thermal Expansion Coef

€ Damping
@ Friction ¢ Density for Material Number 1 ! X
User Ma
Thermal Density for Material Mumber 1
CFD
— Electromagne
e | e i e Tl

-
-
L]
-

Temperatres

DEMS I o

Add Temperature | Delete Temperature | Graph

® Ok | Cancel | Help

Press OK

ANSYS Example0410 15
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size fiYElement Sizes on Picked Lines |
® & pick R [LESIZE] Element sizes on picked lines
SIZE  Element edge length I
(o Single " Box
~ MOTY Mo, of element divisions I [
Polygon (™ gircle
" Loop (NDIY is used only if SIZE is blank or zero)
ENMOIY SIZE,MNDIY can be changed V¥ ‘es
Count = u}
. . _ SPACE  Spacing ratio
Select/Pick S |
Hndnan = AMGESIZE Division arc (degrees) I
L:I- Line Ho. = 2
{ use AMGSIZ only if number of divisions (NOIVY and
{* Lizt of Items element edge length (SIZE) are blank ar zera)
" Min, Max, Inc Clear attached areas and volumes [ Mo
Y — 4 | Ay | Cancel | Help |
Reset Canpel |
Pick ALL Hellp |
— Press OK when finish with selection Enter 30 —
ANSYS Example0410 16
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size fiYElement Sizes on Picked Lines |
® & pick R [LESIZE] Element sizes on picked lines
SIZE  Element edge length I
(o Single " Box
~ MOTY Mo, of element divisions I [
Polygon (™ gircle
" Loop (NDIY is used only if SIZE is blank or zero)
ENMOIY SIZE,MNDIY can be changed V¥ ‘es
Count = u}
. . _ SPACE  Spacing ratio
Select/Pick S |
Hndnan = AMGESIZE Division arc (degrees) I
L2 Line Ho. = 2
{ use AMGSIZ only if number of divisions (NOIVY and
{* Lizt of Items element edge length (SIZE) are blank ar zera)
" Min, Max, Inc Clear attached areas and volumes [ Mo
Y — 4 | Ay | Cancel | Help |
Reset Canpel |
Pick ALL Hellp |
— Press OK when finish with selection Enter 20 —
ANSYS Example0410 17
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking

Count = I

Maximam

Minimam

Line Ho.

NB: It is often necessary to “Clear” the model for
R example if Element Type is to be changed

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS

Example0410 18
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Example — Analysis Type

Write Database Log

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Anal'ﬁ"SIS il I'W'rite non-ezzential cmds as comments LI

[AMTYPE] Type of analysis

File > Write DB log file
Enter “example0410.Igw”

k

" Static

= Modal

" Harmanic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring Press OK

oK @ et HElr:l |

ANSYS Example0410 19
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Example — MA Analysis Optlons

ANSYS Main Menu &] I\ Modal Analysis
= Preferences [MDDOPT] Mode extraction method
Preprocessor e s S el e Ct
B Solution
B Analysis Type " Subspace
New Analysis = _ BlOCk
ExpansionPass Powerdynamics L
anczos
" Reduced
Define Loads .
Load Step Opts " Unsymmetric
Solve " Damped
FSI Set Up : Enter 10
Unabridged Menu " QR Damped
General Postproc Mo. of modes to extract ID— o—
TimeHist Postpro
Topological Opt (must be specified for all methods except the Reduced method)
ROM Tool
Design Dpt R Enter 10
Prob Design Expand mode shapes ¥ Yes
Radiation Opt

NMODE Mo. of modes to expand I o—— I
Run-Time Stats P 0 SWItCh
Session Editor Elcalc Calculate elem results? ™ Mo .—Ii tO YES

Finish

[LUMPM] Use lumped mass approx? ™ No
-For Powerdynamics lumped mass approx will be used
[PSTRES] Incl prestress effects? ™ Mo
[MSAVE] Memory save [~ No
-only applies if the PowerDynamics method is selected P
ress OK
0K @ II Eatreet II HE'p |
ANSYS Example0410 20
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Example — MA Analysis Options

lBlock Lanczos Method | X|
[MODOPT] Cptions for Black Lanczos Modal Analysis

FREQE Start Freq (initial shift) I"j
FREQE End Frequency I o

Nrimkey Mormalize mode shapes IT':' e d

Ok .J Cancel | Help |

Press OK

ANSYS Example0410 21
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 1

¥ pick &— Trpick

Select UX and UY equal zero

ol ingle {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs | X

< Loy [DK] Apply Displacements (U,ROT) on Keypoints
P - 0 Lab2 DOFs to be constrained
Maximum = 2
Minimum = 1
FeyP Ho. =
Appl
{¥ List of Items RSy o ICUHStEIﬂt value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ Ho
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0410 22
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 2

¥ pick &— Trpick

Select UY equal zero

ol ingle {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs | X

< Loy [DK] Apply Displacements (U,ROT) on Keypoirts
P - 0 Lab2 DOFs to be constrained
Maximum = 2
Minimum = 1
FeyP Ho. =
Appl
{* List of Items RSy o ICnnstant value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ o
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0410 23
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ANSYS Main Menu @

Example - Damping

Preferences
Preprocessor
=& Solution
Analysis Type
Define Loads
E Load Step Opts
Output Ctris
B Time,/ Frequenc

-

2 i
ExpansionPass
Other

Solve

FSI Set Up
ADAMS Connection
Unabridged Menu
General Postproc
TimeHist Postpro
Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

A e

ks

I\Damping Specifications
Damping Specifications
[ALFHAD] Mass matriz multiplier

[BETAD] Stif. matrix multiplier

[DMPRAT ] Constant damping ratio

o @ Cancel | Help

o

Press OK ——

Enter 0.02 for Constant damping ratio —

Example0410 24
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0410
Computational Mechanics, AAU, Esbjerg




Example - Solve

Press Close
\i‘) Solution is done!

Press here
to Close

Close @

I\ /STATUS Command . x|
File
[
SOLUTION OPTIONS
PROBLEH DIMENSIONALITY. . . . . . . . . . .. 3.0
DEGREES OF FREEOOH. . . . . - (TR
AT R N W HODAL
EXTRACTION FETHOD. « &« o o o e o e e BLOCK LAKCZ0S
EQUATION SOLVER OPTION. . - - o o o .01 .1 SPARSE
HUHEER OF HODES T ENTRRCT. -« « o o o v o 10
HUHEER OF HODES TO EXPAND . . » .+ o o v o o 10
ELEMENT RESULTS CRLCULATION - « + + » « v o o o
LOAD STEP OPTIONS
LORD STEP WUBBER. . .« v v e v v e e e e 1
FRINT OUTPUT CONTROLS © « - - v v o e e e e N0 PRINTOUT
ORTABASE QUTPUT CONTROLS. — -+« o o o e o ALL DATH HRITTEM
ANSYS Example0410 26
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0410 27
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Example — Results Summary

ANSYS; Main Menu @|

Preferences e
Preprocessor
Solution
B General Postproc
Data & File Opts

aiesults Summar

Read Results

IVSET,LIST Command _

File
|
kit THOEY (OF DATA SETS OH BESULTS FILE - etctetok
SET  TIHESFREQ  LOAD STEP  SUBSTEP  CURULATIME
1 3.309% 1 1 1
¢ 35.054 1 z 2
3 70,893 1 3 3
4 12330 1 9 4
LozanLe 1 g 5
[ 1 fi f
1oaer.oe 1 7 ?
g 42815 1 a a
9 LR4.61 1 9 9
10 669,54 1 1 1
Session Editor j
=~ -
< | +]
ANDT O Example0410
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Example — Read Results

ANSYS; Main Menu @|

Preferences B

General Postproc > Plot Results > Deformed Shape
Preprocessor B

Solution m Plot Deformed ShﬂpE ﬁl

B General Postproc
Data & File Opts [FLDISF] Flot Deformed Shape

Results Summary KUND Items to be plotted
ER-ead Result-|RN | | (O, @000

First Set @ @+ Def shape only
Mext Set
Previous Set " Def + undeformed @——

E Last Set
B:SPiclf " Def + undef edge
By Load Step
By Time/Freq
By Set Number

E FLOTRAN 2.1A oK | Apply | Cancel | Help |
Failure Criteria

Plot Results ®
List Results
Ouery Results
Options for Dutp
Results Yiewer
Write PGR File

NodalColes. Select “Def+undeformed”
Path Operations e and PreSS OK

Load Case
Check Elem Shape |
Write Results

ROM Operations
Submodeling .
Fatigue Read first set
Safety Factor
Define,/Modify j
[— =y .

1 |+

ANSYS Example0410 29
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Example — Mode 1

DISPLACEMENT ANSYS

STEP=1 FEE £4 2004

e 01:23:24
FREQ=3. 308

DM =.062352

ANSYS
Computational Mechanics, AAU, Esbjerg
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Results Yiewer - file.rst
File Edit Yiew Help

Example — Result viewer

]

| &l &l =l

LLi

E”Displaced structure jl j :Iﬁ%—él|@|§l%

|s.3o0031: | 1| 1

Select Animation x|

— Type of Animation Sequence to Capiure

* Mode Shape @
" Deformed Shape
Deformed Results
Cwer Time

Time Harrmonic

Cver Results

Select mode shape, the last

D-5Slice Contours
-Slice Vectors

[sosurfaces

. @ & @ & 8 &

Farticle Flow

mode read is displayed

ar, @ Cancel

Computational Mechanics, AAU, Esbjerg

Press OK

Example0410
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Example — Result viewer

i\ Animate Mode Shape |

Animation data

Mo, of frames to create

Time delay (seconds)

—
T

]

Acceleration Type

&+ Linear

" Sinusoidal

Select DOF
solution and
Def+undeformed

Modal Solution Data
Display Type

x|

Frame 8af 10
50
m BN B
Dielay

* Forward/Backward

" Forward Orly

Stark | Stop |
=2 | Frevious |
Cloze | Help |

DOF solution
Stress
Strain-total Def + undef edge
Ernergy — || Translation LIx
Strain ener dens Ly
Strain-elastic
Strain-thermal ;I IDef + undefarmed
Ok, .J Cancel | Help |
Press OK and animation is controlled
by the following dialog
ANSYS

Example0410

Computational Mechanics, AAU, Esbjerg
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Example — Read Results

[i\Read Results by Data Set Number ]

ANSYS Main Menu
@Il Read Results by Data Set humber
Preferences E|
Preprocessor [SET] [SUBSET] [APPEMD]
Solution

B General Postproc Read results for

IEntire mode| j

Data & File Opts

Results Summary

=R ead Results
First Set
Next Set
Previous Set
Last Set
By Pick
By Load Step
By Time/Freq
By Set Number .——I
FLOTRAN 2.1A

Failure Criteria

Plot Results

List Results

Ouery Results

Options for Dutp

Results Yiewer

Write PGR File

MNodal Calcs

Element Table

Path Operations e

Load Case

Check Elem Shape

Write Results

ROM Operations

MSET Data set number

FACT  Scale factor

- for harmonic elements

2 x|

{List Results Summary to determine data set number)

{Enter YELO for velocities or ACEL for accelerations)
AMGLE  Circumferential location

11

Cancel | Help |

Submodeling
Fatigue
Safety Factor
Define,/Modify j
[— =y .

< [
ANSYS
Computational Mechanics, AAU, Esbjerg

Press OK —

Example0410

Enter 3 and compare with Cook —
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AMSYS Main MMenu

@|

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
Plot Results
Bl List Results
Detailed Summar
Iteration Summry
Percent Error

Element Solution
Section Solution
Superelem DOF
Reaction Solu
Nodal Loads
Elem Table Data
Yector Data
Path Items
Linearized Strs
Ouery Results
Options for Outp
Results Viewer
Write PGR File
Modal Calcs
Element Table
Path Operations

M1 aad Maca

- i

Sorted Listing
odal Solution|k S

-

Example - List

fi\List Nodal Solution _

[FRMSOL] List Modal Solution

H

Itern,Comp  Iem o be listed DOF solution
Stress Translation LI
Strain-total LY
Strain-mech+thrm o LIz
Monlinear items All's  LUCORMP *—
Strain-elastic
Strain-thermal ;I AllDOFs  DOF

[&%PRIM] Eff MU for EQY strain I

oK @ Apply | Cancel | Help |
Example0410 34
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Example - List

I\PRNSOL Command I x|

File

I
FRINT I HODAL SOLUTION PER MODE

LOAD STEP= 1 SIBSTEP= 3
FRED=  70.593 LOAD CASE=

1

wikek POST] WODAL DEGREE OF FREEDOH LISTING ek

THE FOLLOHING DEGREE OF FREEDOH RESULTS ARE IM GLOBAL COORDIMATES

HODE 1H I 11z 115UH
1 0.0000 0.0000 0.0000 0.0000
2 -0.33205E-02-0.17676E-02  0.0000 0.37619E-02
3 0.76118E-02-0.59615E-04 0.0000 0.76120E-02
gk i
6 0.28203E-01-0.23841E-03 0.0000 0.28204E-01 Compare reSUlt Wlth COOk |-
7 0.33632E-01-0.29795E-03  0.0000 0.33634E-01
4 0.38057E-01-0.35753E-03  0.0000 0.38053E-01
9 0.41346E-01-0.41704E-03 0.0000 0.41343E-01
10 0.43405E-01-0.47653E-03  0.0000 0.43403E-01
11 0.44151E-01-0.53598E-03  0.0000 0.44134E-01
12 0.43657E-01-0.59538E-03  0.0000 0.43661E-01
13 0.41861E-01-0.65474E-03  0.0000 0.41866E-01
14 0.38859E-01-0.71405E-03  0.0000 0.38565E-01
15 0.34758E-01-0.77330E-03  0.0000 0.34766E-01
16 0.29700E-01-0.83250E-03 0.0000 0.29711E-01
17 0.23860E-01-0.89162E-03 0.0000 0.23877E-01 @&—
13 0.17442E-01-0.95068E-03  0.0000 0.17463E-01
19 0.10669E-01-0.10097E-02 0.0000 0.10717E-01
20 0.37842E-02-0.10656E-02  0.0000 0.39322E-02
21 -0.29622E-02-0.11274E-02  0.0000 0.31695E-02
22 -0.93152E-02-0.11861E-02  0.0000 0.93904E-02
23 -0.15023E-01-0.12448E-02  0.0000 0.15074E-01
24 -0.19841E-01-0.13033E-02  0.0000 0.19334E-01 LI
2L -0 2R F-M-1.13R1A8F-02 0000 (1. #353NF-1
ANSYS Example0410 35
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Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?'Sis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0410.Igw”

k

" Static

i Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oKk @ Eatreet HE.‘||'J |

ANSYS Example0410 36
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Example — HRA Analysis Op

AMNSYS Main Menu

2 Preferences
Preprocessor
B Solution
B Analysis Type
. New Analysis
ExansmnPass

E Define Loads
Load Step Opts
Solve
FSI Set Up
Unabridged Menu
General Postproc
TimeHist Postpro
Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

Ii\Harmonic Analysis
[HROPT] Solution method

_l»

[HROUT] DOF printout format

IReaI + imaginary

d‘

[LUMPE] Use lumped mass approx? [ Mo

—® OK |

ANSYS

Cancel | Help |

I Full Harmonic Analysis

Options for Full Harmonic Analysis
[EQSLY] Eguation sokver

Tolerance -

- valid for all except Frontal Solver
[PSTRES] Incl prestress effects?

® Ok Cancel |

Frontal solver

tions

' L— Select Full

Select

— Amplitud+

phase

Press OK

Computational Mechanics, AAU, Esbjerg

Example0410

37



Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on

v pick .—f"—unprmz—J

Select keypoint 3

v 5 ingle { Box

" Polygon { Circle

G Change to FX
Count = O I\ Apply F/M on KPs X
Mzximum = 2 [Fk] Apply ForceMoment on Keypoints
Minimum = 1 Lab  Direction of force/morm Im
EeyP HNo. =
Apply as ICDnstar'lt value j

{* List of Items If Constant value then:

{" Min, Max, Inc YALUE  Real part of force/morm I °
| YaLUEZ Imag part of force/mom I

®
EE S (034 J Apply Cancel | Help |

BEeset Cancel —
Pick 211 Help ‘
Press OK to finish Enter 3000
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Example - Freq and Substps

AMSYS Main Menu

®|

Preferences
Preprocessor
E Solution
Analysis Type
Master DOFs
Define Loads
H Load Step Opts
Output Ctris
Solution Ctrl

Monlinear
ExpansionPass
Other
Reset Options
Read LS File
Write LS File
Initial Stress
Physics
Solve
FLOTRAN Set Up
Run FLOTRAN
FSI Set Up
General Postproc
TimeHist Postpro
Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

FEEEEEEEHE

-

B Time/Frequenc
Freq and Substpsi08

4

Fi\Harmonic Frequency and Substep Opt;

Harmonic Frequency and Substep Options
[HARFRD] Harmonic freq range

[NSUBST] Mumber of substeps

[KBC] Stepped or ramped b.c,

(0] 4 | Cancel |

— Enter 50

— Enter 160

=4

&+ Ramped

Enter 110

®
" Stepped

Help |

ANSYS

Example0410
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ANSYS Main Menu @

Example - Damping

Preferences
Preprocessor
=& Solution
Analysis Type
Define Loads
E Load Step Opts
Output Ctris
B Time,/ Frequenc

-

2 i
ExpansionPass
Other

Solve

FSI Set Up
ADAMS Connection
Unabridged Menu
General Postproc
TimeHist Postpro
Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

A e

ks

I\Damping Specifications
Damping Specifications
[ALFHAD] Mass matriz multiplier

[BETAD] Stif. matrix multiplier

[DMPRAT ] Constant damping ratio

o @ Cancel | Help

o

Press OK ——

Enter 0.02 for Constant damping ratio —

Example0410 40
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0410
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Example - Solve

Press Close
\ij) Solution is done!

Close @

ANSYS Example0410 42
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Example TlmeHlstoryPostpro

Time History Yariables - file.rst

AMNSYS Main MMenu

File Helm

Preferences -

Preprocessor r _| ﬁl _I EI El IN'I'HB = El il

Solution Variable List

Real

General Postproc

- MHarme Element  [Maode Result Ikem
Yariable Yiewer
Settings

Store Data
Define Variables
Read LSDYNA Data 4 |

I+linimum Waximum H-hxis

List Yariables

Calculator

List Extremes
Graph Variables
Math Operations

Table Operations ( ) I jl
Smooth Data

Generate Spectrm MM COM]  &™

Reset Postproc
Topological Opt

P& a+ib LM 7 g 9

CLEAR

ROM Tool RCL
Design Opt

Prob Design =TO LOG 4 3 8

Radiation Opt
Run-Time Stats
Session Editor 4BS | ATAM #2 il 2 3

NS IMEM SORT

AoEpEEEE

Finish INT1 IMAG

I DERIY | REAL 1]

Am-4=Zm

<] |21 Example0410
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Example — Define Variables

ANSYS Main Menu o

W

Defined Time-History ¥ariables

Preferences
Preprocessor
Solution Yariable Type Elem Mode Item Comp Mamea
General Postpr i TIME TIME
B TimeHist Postpi

Yariable Yiex

Settings

Store Data

Read LSDYM,

List Yariable

List Extreme

Graph Variak

Math Dperat

Table Dperal

Smooth Dat:

Generate Sp

& Reset Postpi Add....ll Edit... | Delets |

Topological Opt

Currently Defined Specifications:

ROM Tool
Design Opt Close | Help |
Prob Design

Radiation Opt
Run-Time Stats
Session Editor
= Finish

FEEREEEEE

Press Add

<] |21 Example0410
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Example — Add Time-History Var.

I\ Add Time-History Variable x| Define Nodal
Type of variable
i B el @ € ra O o
o
Element results Select Nodal o e
... by seqg no.
o DOF result S s cacas
" Reaction forces {" Loop
" Gap Force data
C = 1
" _Solution summary PreSS OK - i
Maximum = 1
Minimum = 1
| |
e | st _teb | Node No. = 2

IDefine Nodal Data

[MNSOL] Define Modal DOF variable

{* List of Items

R [ Hin, Max, Inc
My AR Ref number of variable I— Enter 17
MODE Mode number I— _H'.
Mame User-specified label I—
Item,Comp Data item Fm Translation L j Press OK —_5 0K Apply
LY
. Lz Reszet Cancel
Rotation  ROTX
EOA RS || Pick ALL Help
ITransIatmn ¥
) canc | o Select DOF §o|ut|on
and Translation UX
ANSYS —— Press OK Example0410 45
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Example

ANSYS Main Menu @ [\ Graph Time-History Variables
Preferences S [FLv&R] Graph Time-History Yariables

Preprocessor
Solution
General Postproc
E TimeHist Postpro il
Variable Viewer
B Settings MRS
File Ny AR
Data
List MY ARS
Graph
Store Data MY ARE
Define Variables
Read LSDY¥NA Data MY ART
List Yariables
List Extremes M ARE
Math Operations My ARG
Table Operations

MyaR1

Generate Spectrm
Reset Postproc
Topological Opt
RO Tool
Design Opt
Prob Design

smooth Data MyAR 10 10th variable

oK @ Apply | Cancel | Help |

— Graph Variables

1st variable to graph

2nd variable
3rd variable

4th variable

Enter 2 to plot
UX for node 17

Sth wariable
&th variable
7th variable
8th variable

Oth variable

LTS

Radiation Opt
Run-Time Stats

Session Editor
Finish

ALl o

Corﬁpljtational Mechanics, AAU, Esbjerg
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Example — Graph Variables

; POSTEG ANSYS

FEE 24 2004

AMPLITUDE
LN

ANSYS Example0410
Computational Mechanics, AAU, Esbjerg
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