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Example — Drill pipe 3D

y
[ p
p Y
I N AR R —
Objective: " E = 210000N/mm?
Display the stress distribution v =03
Tasks: p = 100N/mm

How should this be modelled?

Build an axi-symmetric model

Topics:

Element type, Real constants, modeling,
Plot results, output graphics
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Example — Read Input from

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help
Clear & Start Mew ...

Change Jobname ... Read File |

iChange Directory ...

Read input from Drirectaries: 0.
Change Title ... [ -

.—E-"I"._I".ﬁ'dfﬁﬁ‘u g=laui
Cancel
Resume Jobname.db ... gsviewddini ] [ Documents and Se = | 4'
seratch.hip E= Adminiztrator Hel
Resume fram ... £ Cookies J elp |

1 Dokurnenter

Save as Jobname.db £ Foretrukne

Sawe as ... E £ Menuen Stat = |

Write DB log file ... Lizt Files of Type: Drives:

Read Input from . | 41 Files = [=- ] Mework. |
Swritch OumUt o E Dptional line number or label

List b |

File Cperations 4

; ; [” Copy input to databaze log
AMNSYS File Options ...

Import 4

Export ... Browse to find drill-pipe-axi.lgw —

Report Generatar ...

Exit ...
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Example — Read Input from
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Example — Create Areas by line

ANSYS Main Meny @|

Preferences
B Preprocessor
Element Type
Real Constants
Material Props
Sections
E Modeling
El Create
Keypoints
Lines
E Areas
=RArbitrar
A Through K
A Overlaid o

& By Lines®
2 By Skinnin
A By Dffset —
Rectangle
Circle
Polygon
# Area Fillet
Yolumes
MNodes
Elements
Contact Pair
Piping Models
Circuit
Racetrack Coil
Transducers
Operate
Move / Modify j

[ Mo

Create Area b

(o) Pick @ — Trprick

(o Single " Box

) olygon ) Circle
- Loop

1]
]

Conart

Marimuam 10

1]
[}

Minjimuam

Line MNo. =

{¥ List of Items

- Min, Max, Inc

O @—f——ippls

Select All lines

= | B

ANDTO

Computational Mechanics, AAU, Esbjerg

Beset Cancel
Picl: A1L Halp
Example0304

Press OK to finish



Example — Create Areas by line
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types i x|
- e - >
e e T Ii\Library of Element Types ]
MOME DEFINED Library of Element Types Structural Mass A |Quad 4node 42 -
Link: [ dnode 182
Bearm Brode 153
Fipe Brode 82
Rigid Triangle tnode 2 -
Brode 183

Element type reference number

04 | Aoy | Cancel | Help |

Add... |e Sptions- Selete Press Add
Clase | Help |
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

Defined Element Types:

PLANELS3

Press Options

add... Dptions. .. | [ Belate
Cloze | Help |

ANSYS Example0304
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete

FYPLANE183 element type options

Options for PLAMELS3, Element Type Ref, Mo, 1

Element behavior k3

Elerment output coordinates K4

Flarne stress j

Plane stress

Select Axisymmetric

Axisymmetric @
Plane strain e
Element: formulation K& Plane strs wthk -
(MOTE: Mixed formulation is not valid with plane siress)
User defined initial stress K10 IN':' USTRES routmn j
Ok, | Cancel | Help @
ANSYS Example0304
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Press Help to learn
more about the
element.




Example — Real Constants

No Real Constants are necessary for axi-symmetric models!

ANSYS Example0304
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0304 11
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter 210000 |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter 0.3
S S Poisson’s ratio
Temperatures
EX
PRXY ] 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0304
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Example - Meshing

Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
®| |
Select individual areas

AMNSYS Main Menu ANSYS Main Menu AMNSYS Main Menu

Preferences
E Preprocessor

Preferences
E Preprocessor

Preferences
B Preprocessor

Element Type Element Type Element Type _
Real Constants Real Constants Real Constants * pick@——tmpick to be meshed
Material Props Material Props Material Props
Sectiu_ns Sectiu_ns Sectiu_ns * Single e
Modeling Modeling Modeling
E Meshing B Meshing B Meshing " Tolygonm ¢ Cirele
Mesh Attribute: Mesh Attributes Mesh Attributes . )
MeshTool MeshTool MeshTool N B . It IS Often
Size Cntrls Size Cntrls Size Cntrls '
Mesher Opts Mesher Dpts Mesher Opts Count = 0 0 n
Concatenate Concatenate Concatenate Maximum = 1 necessary to Clear
B Mesh B Mesh 2 Mesh
# Keypoints A Keypoints A Keypoints Minimum = 1 the mOdel for
& Lines A Lines # Lines .
Area No. =
o 8 Areas 5 Areas el example if Element
Mapped =i B Mapped
2 Free #1 By Corners 21 By Corners Ol hen Gf Tetme Type or mOdeI
#1 Target Sur 213 or 4 sided P2
Volumes Concatenate Concatenate

Yolume Swee

Tet Mesh Fro

Interface Me:
Modify Mesh
Check Mesh
Clear

Del Concats
& Free
A Target Surf
Yolumes
Volume Sweep
Tet Mesh From

Del Concats

# Free

- Min, Max, Inc

A Target Surf ||

Yolumes
Yolume Sweep
Tet Mesh From

Computational Mechanics, AAU, Esbjerg

geometry is to be
changed

Select all areas defined
to be meshed

Checking Ctrls Interface Mesh Interface Mesh 0E Apply
Numbering Ctrls Modify Mesh Modify Mesh
Archive Model Check Mesh Check Mesh Deset CaaeD
Coupling / Ceqgn Clear Clear
FLOTRAN Set Up Checking Ctrls Checking Ctrls i
F5I Set Up Numbering Ctrls Numbering Ctrls Pl‘:k.‘a‘ll Help
Loads Archive Model Archive Model j
| | [ |+
ANSYS Example0304
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Example - Meshing

1
ELEMENTS

ANSYS Example0304
Computational Mechanics, AAU, Esbjerg
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Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0304.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0304 15
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Lines

Apply U,ROT Select Line L8 Select UY to fix the pipe in the y-direction
¥ pick @&—mmpic . 3
Fick e I Apply UROT on Lines x|
{¥ Zingle { Eox [OL] Apply Displacements (LROT) on Lines
" Polygon ( fircle Lab2 DOFs to be constrained &l DOF
i Loop
Count = 0]
Maximuam = 4
Minimuam = 1
Line Mo. =
{¥ List of Items all DOF
- Min, Max, Inc
Apply as ICDnstant valLe j
YALUE  Displacement value I
0E @ p-nz) s oK @ | Apply | Cancel | Help |
Reset Cancel
Pick All Help
— Press OK
ANSYS Example0304 16
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Pressure > On lines

I\ Apply PRES on lines |

Apply PRES o

+ pick @&—trpick

[SFL] Apply PRES on lines as &

ICDnstant value

If Constant value then:
YALUE Load PRES walue

.

If Constant value then:
Cptional PRES values at end 1 of line
{leave blank for uniform PRES
Yalue

i Single " Baoj .
= Select line
- Loop L4

Conart = 1

Marximum = =

Minjimum = 1

Line Ho. = £ Enter '100

{¥ List of Items

- Min, Max, Inc
!

0E @ Zprpriyr
Beset Cancel PreSS OK
Pick ALl Help to finish

Note: Pressure acts normal and

ANWERY to a surface _
Computational Mechanics, AAU, Esbjerg

————@ Ok | Apply |

Canicel |

Help |

Example0304
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Example - Save

1
LINES

LINE NUM

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

!

ANSYS Example0304 18
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0304
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Example - Solve

Press Close

_ i ) Solution is done!

Press here
to Close
:
I /STATUS Command L X
File
I
SOLUTION OPTIOMNS

PROBLEH DIHENSIONALITY. © o v v v v v v v o s AXISYHHETRIC

OEGREES OF FREEDOH. . . . . . TR

R S E— STATIC (STEADY-STATE)

LOARD STEP OPTIONS

LOAD STEP HUBBER. + v v v v v e v v e e w e 1

TIHE AT END OF THE LOAD STEP. . . . » . o oo . 1.0000

HUHBER OF SUBSTEPS. . v v v v o v v v v oo 1

STEP CHAMGE BOUNDRRY COMDITIONS . . . . . . . . H

PRINT OUTPUT CONTROLS .+ v v v v v v v v v o HO PRINTOUT

ORTRBASE OUTPUT CONTROLE. & & & v v v v v o s ALL DATH HRITTEN

FOR THE LAST SUBSTEP
ANSYS Example0304 20
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Example - PostProcessing

AMSYS Main Menu

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
= Plot Results
Deformed Shape
B Contour Plot
Element Solu
Elem Table
Line Elem Res
Yector Plot
Plot Path Item
Concrete Plot
List Results
Query Results
Options for Outp
Results Yiewer
Write PGR File
Modal Calcs
Element Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Operations
Submodeling

F Fatirmo

s [ ]

El

KUND  Items fo be plotted

Fact Optional scale factor

[/EFACET] Interpolation Nodes

[4%PRIN] Eff MU for EQY strain

Item,Cormp  Item to be contoured

Apply |

@'l I\ Contour Nodal Solution Data

[PLMSOL] Contour Modal Solution Data

DOF solution

Strain-total
Strain-mech+hrm
Energy

Strain ener dens

Strain-elastic ;I

" Def shape only

3rd principal 53
Intensity  SINT

von Mises  SEQY
PlasEqwSirs SEPL
StressRatio SRAT

I von Mises  SEQW

* Def + undefarmed | @

" Def + undef edge

e

% Corner only
" Corner + midside

" all applicable

—

Cancel |

 I—

Help

Select “Def+undeformed”
and Press OK

ANSYS

Computational Mechanics, AAU, Esbjerg
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Example - PostProcessing

NODAL Z0LUTION ANSYS

. FEE 23 2004
e ZZ:157:04
TIME=1

SEQV [AVE)

DI =. 363366

SMN =35.744

SMD =114, 042

LX

38.744 55.477 Fz.21 95.943 105.676
47.111 63.844 80.576 97.309 114.04z2

Read Maximum displacement: DMX
ANSYS Example0304
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