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Example — Flap

Objective:
Compute the critical buckling load and display
the mode shape
—— (20,13500) Tasks:
. o i
v(c) Display the deflection figure”

(20,135,10)

_(20,135,30)

{20,135,40)

E = 210000N/mm?
r=0.3

h=2mm
F=1.2N

{10,135,30)

(100,0,40)
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0301 ¢ Command line entry
x| Enter: Example0301

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Flap
[title, Flap
x|
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0301 3
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ANSYS Menus - WorkPlane Menu

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help
Display Working Plane
Show WP Status
WP Settings ...

Offset WP by Increments ...

Offset WP fo ¢
Align WP with +
iChange Active CS 1o P e— Global Cartesian
iChange Display CS to ¢ Global Cylindrical @
Local Coordinate Systems ¥ Global Cylindrical ¥
Global Spherical
Specified Coord Sys ...
Working Plane
Select Global Cylindrical —
ANSYS Example0301
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Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS

Note: An empty #
result in automatic
numbering.

G £ . # Keypoint number
eneral format:  x Keypoint x-coordinate

K#,X,Y,Z Y Keypoint y-coordinate
Z Keypoint z-coordinate

Enter the keypoints
from the figure

Create Keypoints in Active Coordinate Systen Ed
[K] Create Keypoints in Active Coordinate System
MPT  Keypoint number I
¥,¥,Z Location in active CS | ° I I

0]4 Aoy ® Earee Heds

4| 4| Note: An empty box
result in a zero.
ANSYS Example0301 )
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Example - Keypoints

' ANSYS

POINTS
FEE 13 Z0O04
01:29:12

POIN NUM

ANSYS Example0301
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2 and so on.
L,1,2

L,2,3 Create Straig HINT: By clicking with the right-
@ Pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
S O arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel
to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help

ANSYS Example0301
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Example - Lines

' ANSYS

LINEZ
FEE 18 Z00O4
0Z:18:59

TYFE NUM

ANSYS Example0301
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Example - Areas

Preprocessor > Modeling > Create > Areas > Arbitrary > By Lines
Create 2 areas

HINT: By clicking with the right-
P hand mouse button you shift
F——-— between the Pick/Unpick
€ bolyson ¢ cirele function. This is indicated by
L Jier the direction of the cursor
Cowne = 0 arrow:

Maximuam

Minimuam

n [} [}
I

Pick: upward arrow

Line Mo.

Unpick: downward arrow

{* List of Items

i Min, Max, Inc

Press OK or Cancel
! to finish selection

0K @ gk

Leset Cancel |@

/ Piglk ALL Help ExampleOSOl
Computanorarvrecrranics, AAU, Esbjerg




Example - Areas

g ANSYS

LINE3
FEE 18 2004
02:18:59

TYFE NUM

ANSYS Example0301
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Example — Change CS

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help

Display Working Plane
Show WP Status
WP Settings ...

Offset WP by Increments ...
Offset WP fo
Align WP with

iChange Active CS 1o
iChange Display CS to
Lacal Coordinate Systems

*—— Global Cartesian @

ANSYS Example0301
Computational Mechanics, AAU, Esbjerg

Global Cylindrical
Global Cylindrical v
Global Spherical

Specified Coord Sys ...
Working Plane

Select Global Cartesian —

11



Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|

e BTt e li\Library of Element Types |

Library of Elerment Types Structural Mass M Elastic 4node 63
Link — Bnode 03
Bearn Plastic 4nodel43
Fipe Hyper 4nodel8l
Rigid Plastic 4node 43 -
Solid

» | | Elastic 4node 63

Element type reference number I 1
04 | Aoy | Cancel | Help

Add...e Estions. Berets
— — Press Add
Close | Help | Select Shell, Elastic 4node 63
ANSYS Example0301 12
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Example - Element Type

i\ SHELL63 element type options i X]
Options for SHELLG3, Element Type Ref. Mo, 1

Element Types , Elerment stiffness K1

Stress stiffening option K2 IMain tratr iz j

Defined Element Types:

SHELLGEZ Extra displacement shapes K3 IIr‘u:Iude j
Exfra stress output K3 IN.;. exira output j
Pressure loading K& IReduced lnading d
Mass matrix K7 ICunsistent j
Stiffiess matrix K8 ICDngistent d
Elerment coord sys defined by K9 IEIem ariertation j
Store Mid data on rst file K11 KO -

Ok | Cancel | Help | L

add... Delets
Press Options
_ces | _ren | Press Help to learn more about the |
element.
ANSYS Example0301 13
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 SHELLGZ

04 ®

Cancel

Place the cursor
on the relevant
element and
press OK

Example0301

Computational Mechanics, AAU, Esbjerg
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Example - Real Constants

Preprocessor > Real Constants > Add
= Enter Defined Real Canstant Sets

Fi\Real Constant Set Number 1, f thickness 2
Elernent Type Reference Mo, 1
Feal Constant Set Ma.
Shell thickness at node I TK(T P

at node J TKDY o—

atnode K TEED o—

atnode L TE(L) *———

Elastic foundation stiffness EFS
Element #-axis rotation THETA
Bending mam of inertia ratio RMI

Dist from mid surf o top CTOP :
Edit... Delete

Dist from mid surf to bot  CBOT

T RS

&dded massfunit area ADMSLLA

Ok, Ol Apply | Cancel | Help |

Press Close to finish

ansys Fress OK Example0301 15
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Example - Material Properties

Preprocessor > Material Props > Material Models

Linear Isotropic Properties for Material [

Linear Isotropic Material Properties for Material Mumber 1

x/| Enter: Click here
Modulus of elasticity to Close
Enter: ‘

il
Temperatures
EX 210000 ®
PRI 4

add Temperature | Delete Temperature |

OF. |

Cant

ANSYS

Computational Mechanics, AAU, Esbjerg

Poisson’s ratio

F\nofine Material Model Behavior
Material Edit Help

— Material Models Defined

& Material Model Nurnber 1
& Linear Isotropic

— Material Models Available

iz @8 Structural
|ﬁ Linear
8 Elastic

€ Orthotropic
& Anisofrapic
MNonlinear
& Density
Thermal Expansion Coef
# Darmping

(] & Friction Coefficiant
If (Zm | lemw W chmwrim] inbimune
»

o™

Example0301
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size
——@®  {* pick " Unpick
{* zingle " Box
" Polygon ¢ Circle
- Loop
Count = 0
Select/Pick ~ lexima =
LlneS tO Line Ho. =
SpeCIfy ¢ Lizt of Ttems
mesh size ol T
for
|
Pick L2 and e
IPELT
L11
Reset Cancel
Pick All Help
ANSYS

Computational Mechanics, AAU, Esbjerg

fi\ Element Sizes on Picked Lines x|

[LESIZE] Element sizes on picked lines

SIFE Element edge length I

MDY  Mo. of element divisions I 7 *——————

(MDIV is used only if SIZE is blank or zero)

KYNDIV SIZE,NDIV can be changed ¥ Yes

SPACE Spacing ratio I

ANGSIZ Division arc (degrees) I

( use ANGSIZ only if number of divisions (NDIV) and

element edge length (SIZE) are blank or zero)

Clear attached areas and volumes I Mo

oK | Apply | Cancel | Help |
,—‘ Enter 3 —
Press OK when finish with selection
Example0301 17




Example — Mapped Meshing

Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
®| |
Select all areas to be

AMNSYS Main Menu ANSYS Main Menu AMNSYS Main Menu

Preferences
E Preprocessor

Preferences
E Preprocessor

Preferences
B Preprocessor

Element Type Element Type Element Type _
Real Constants Real Constants Real Constants * pick@——tmpick meshed
Material Props Material Props Material Props
Sectiu_ns Sectiu_ns Sectiu_ns * Single e
Modeling Modeling Modeling
E Meshing B Meshing B Meshing " Tolygonm ¢ Cirele
Mesh Attribute: Mesh Attributes Mesh Attributes . )
MeshTool MeshTool MeshTool N B . It IS Often
Size Cntrls Size Cntrls Size Cntrls '
Mesher Opts Mesher Dpts Mesher Opts Count = 0 0 n
Concatenate Concatenate Concatenate Maximum = 1 necessary to Clear
B Mesh B Mesh 2 Mesh
& Keypoints 2 Keypoints A Keypoints Minimum = 1 the mOdel for
& Lines A Lines # Lines .
A Ho. =
o 8 Areas 5 Areas el example if Element
Mapped =i B Mapped
2 Free #1 By Corners 21 By Corners Ol hen Gf Tetme Type or mOdeI
#1 Target Sur 213 or 4 sided P2
Volumes Concatenate Concatenate

Yolume Swee

Del Concats

Del Concats

- Min, Max, Inc

geometry is to be

Tet Mesh Froi # Free # Free
Interface Me: A Target Surf A Target Surf || Changed
Modify Mesh Yolumes Yolumes

Check Mesh
Clear

Volume Sweep
Tet Mesh From

Yolume Sweep
Tet Mesh From

Checking Ctrls Interface Mesh Interface Mesh 0E Apply
Numbering Ctrls Modify Mesh Modify Mesh
Archive Model Check Mesh Check Mesh :
Coupling / Ceqgn Clear Clear itk Eaneed SeIeCt a-” areas deflned
FLOTRAN Set Up Checking Ctrls Checking Ctrls i
FSI Set Up Numbering Ctrls Numbering Ctrls Pl‘:k.‘a‘ll Ay to be meShed
Loads Archive Model Archive Model j
‘| «| 351 o |
ANSYS Example0301 18
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Example Mapped Meshing

ANSYS

FEE 18 2004
OZ:22:07

ELEMENT=

ANSYS Example0301
Computational Mechanics, AAU, Esbjerg




Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0301.Igw”

k

" Modal

" Harmonic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oK @& Eateel Help |

ANSYS Example0301 20
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Example — Plot - Lines

' ANSYS

LINES
FEE 18 Z004
0Z:23:28

LINE HUM

ANSYS Example0301
Computational Mechanics, AAU, Esbjerg




Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Lines

Apply U,ROT | Select L5 and L9 Select All DOF to fix/clamp the flap
® pick &—tmprn I Apply UROT on Lines ' x|
{* 2ingle { Eax [OL] apply Displacements (LULROT) on Lines i
" Polygon mircle Lab2 DOFs to be constrained 4| DOF
i Loop
Count = u]

Maximum = 4 §g$§
Line Mo. =
{¥ List of Items all DOF
- Min, Max, Inc
Apply as ICDnstant value j
YaLUE  Displacement value I
N T oK @ | Apply | Cancel | Help |

Reset Cancel

Pick All Help
— Press OK
ANSYS Example0301 22
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ANSYS

Fan Zoom Rotate ..
Yiew Settings

WiorkPlane Parameters

Macro  MenuChrls

Example — Node numbers

File Select List Plot PlotCirls

Help

Murnbering ...
Symbals ...
Style

Font Controls
YWindow Controls
Erase Options

Animate
Annotation

Device Cptions ...
Redirect Plots
Hard Copy

Save Plot Cirls ...
Festore Plot Cirls ...
Reset Plot Cirls

Capture Image ...
Festare Image ...
Write Metafile

Multi-Plot Contrals ..
rAL =Y indowe Layout

Best Quality Image

Computational Mechanics, AAU, Esbjerg

li\Plot Numbering Controls

® [/PHUM] Plot Murmbering Confrols
KF  Keypoint numbers [ of
LINE Line numbers [~ off
AREA Area nurmbers [ of
YOLU Yalume numbers [ of
MODE Mode numbers [ of e—
L Elem / atirib numbering IN':' numbering ;J
TABM Table Marnes [~ Off
SWal Mumeric contour values [ of
[MUR] Murnbering showe sweith ICDIDrs & rumbers ;j
[/REFLOT] Replot upon OK/apply? IRepIDt LI
04 I Apply | Cancel I Help |
Switch on Node numbers —
xample0301 23




Example — Plot - Elements

ANSYS Example0301
Computational Mechanics, AAU, Esbjerg



Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes

Apply F/M on

@ pick @—tmptor—

v Single {~ Box

" Polygon " Circle
[ Loop

I
[}

Count
Maximuam 1

Minimuam

[} [} ]
=

Node Mo.

{¥ List of Items

- Min, Max, Inc

Select nodes 1, 14, 13, 9

Select FY
I Apply F/M on Nodes x|
[F1 Apply ForceMoment on Modes
Lab  Direction of force/morm PY Iw v|
Apply s ICl:unstant value j

If Constant value then:

0E @ Eprprier
Reset Cancel
Pick A1l Help
ANSYS

YALUE  Force/morment value I
j |

(]34 OJ Apply Cancel | Hel

—

Press OK to finish Enter -1.2

Example0301 25
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il

ELEMENTS

AMEYS Toolbar

SANE_DB

RESLIM_DB

QUIT

FOVYRGEPH

E-CAE

ANSYS

Computational Mechanics, AAU, Esbjerg

Example0301

Example - Save

Save the model

Display of Analysis model

26



Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0301
Computational Mechanics, AAU, Esbjerg




Example - PostProcessing

Solution > General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0301 28
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Example - PostProcessing

ANSYS Example0301
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Example — Contour Plot

I Contour Nodal Solution Data

ANSYS Main Mernu @l [PLMSOL] Contour Modal Solution Data

— Itern,Cornp  Itern to be contoured DOF solution Intensity  SINT =
Preferences =] IS vor Mises  SEQY
Preprocessor Strain-total PlasEqvStrs SEPL

Solution Strain-mech+thrm StressRatio SRAT

B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria KUMD Items ta be plothed
B Plot Results

Deformed Shape

Energy
Strain ener dens
Sirain-elastic

HydrostPres HPRE =

wor Mises  SEQW

= Def shape only

B Contour Plot &+ Def + undeformed
ESIGHET " Def + undef edge
E:Em?:hlgeulu Fact Optional scale factor I 1
Line Elem Res [/EFACET] Interpolation Modes

Yector Plot = Corner only

Plot Path Item

Concrete Plot
List Results Al applicable
Query Results
Options for Outp _
Results Viewer L [&%PRIN] Eff MU for EQY strain |
Write PGR. File
Modal Calcs
Element Table
Path Operations —@ oK Appl Cancel Hel
Py ® o | __eeply_| _carcel | _tep |
Check Elem Shape

" Corner + midside

Write Results
ROM Operations

® Submodeling r Press OK — Select Stress, von Mises SEQV

F Fatirmio

+ ]
ANDTY O Example0301 30
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Example — Contour plot

ANSYS

FEE 18 Z004
02:37:42

HODATL SOLUTION

STEP=1

SUB =1

TIME=1

SEQV (AT
DME =.583387
SMN =1.556
SME =45,338

ANSYS Example0301
Computational Mechanics, AAU, Esbjerg




Example — Comments/Questions

 The “example0301.lgw” can be edited In
“Notepad”

 Change element type to 6-noded
triangular elements? Will this affect the
result?

 Will the number of elements affect the
solution?

ANSYS Example0301 32
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit... Example0301

Computational Mechanics, AAU, Esbjerg
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