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Example — Cantilever beam

I F

7

X

d L »
Objective: E = 210000N/mm?
Compute the maximum deflection and locate v =03
point of maximum deflection L =2100mm
Tasks: a=10mm
How should this be modelled? b=10mm
Compare results with results obtained F = 100N
from beam theory?
Topics:

Element type, Real constants, modeling,
Plot results, output graphics
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0300 e Command line entry
| Enter: Example0300

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
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Example - Areas

Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions
Create an area given by X=(0,100) and Y=(0,10)

ANSYS Main Menu @] Enter O or
'references
reprocessor r Ieave e m pty

H Element Type . . —
7 Real Constants i\ Create Rectangle by Dimensions _ x|

H Material Props
# Sections [RECTMG] Create Rectangle by Dirmensions Entel’ 100

1 Modeling )
B Create ¥1,¥2 ¥-coordinates I

° |
Keypoints .
E Lines 1,%2 Y-coordinates I PS I

B Areas
Arbitrary

B Rectangle
& By 2 Corners ok, OJ Apply | iZancel | Help |
By Centr & Cornr 9

By Dimensions
H Circle
_F‘?E’E‘E’.}et Enter O or Enter 10
2 —— Press OK leave empty

Contact Pair
Piping Models
Circuit
Racetrack Coil

BT T Note: Keypoints (4 kp’s) and lines
perate

Move ; Modify (4 lines) are automatically generated
e (also numbered automatically)
Check Geom
Delete

Cyclic Sector

5 R |,|j Example0300 4
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Example - Area

g ANSYS

AREAS
FEE 11 Z004

083:31:39

TY¥FE HUM
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Example - Operate

Preprocessor > Modeling > Operate > Extrude > Areas > Along Normal
Create a volume by extruding the area 10 along its surface normal vector

ANSYS Main Menu @

Preferences =]
B Preprocessor

Element Type

Real Constants

rMaterial Props

Sections

Keypoints
& Extend Line
Booleans
Scale
Calc Geom Items
Move / Modify
Copy
Reflect
Check Geom
Delete
Cyclic Sector
Genl plane strn
Update Geom
Meshing
Checking Ctrls
Numbering Ctris
Archive Model d

/
| [+

Extrude Area

% piclk - Tnpick

= Single {" Box

€ Polygon {0 Cirele

B Modeling " Loop
Create
B Operate Count = 0
E Extrude
Elem Ext Opts miEeptmem, = 1
= M Minimam = 1
#1 Along Normal @- P T
Z1 By X¥2Z Offset ’
& About Azis [
&1 Along Lines {* List of Items
Lines

- Min, Max, Inc

I\ Extrude Area along Normal

[VOFFST] Extrude Area along Maormal

MAREA Ares to be extruded
DIST Length of extrusion

KIMNC  Eeypoint increment

oK @ Apply

112

Help |

0K @ Fgerierdsy
Beset Cancel
Picl A11 Help

— Press OK

Note: Bottom left corner of ANSYS GUI

| 'OFFST1 Pick or enter the area to be extruded

Example0300
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Example — Mouse rotate

1
WOLTMES

TY¥FE HNUM

ANSYS

FEE 11 Z004
08:49:32

ANSYS
Computational Mechanics, AAU, Esbjerg

Example0300

Rotate by
holding the
Ctrl key
down while
using the
right hand
mouse
button




Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

Defined Element Types: l\Library of Element Types

NONE DEFINED Library of Element Types

Element type reference number

04 | Aoy |

X

Structural Mass
Lirik
Beam
Pipe
Rigid

Cancel |

| I

Snode 83

Brick Bnode 45

Snode 185

20node 95

20node 186

Help |

Add... |@ Esbons. Belets
Clase | Help |
ANSYS Example0300
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Press Add




Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete
Element Types x|

E'j Elemem [ SOLID186 element type options X

Cptions for SOLIDA8S, Element Type Ref, Mo, 1

Elerment technology K2 IReduced integr j
Elerment output coordinates K4 IGIDhaI Systerm j

Elerment formulation K& Ipure displacemnt j
User defined initial stress K10 IN':' USTRES routh j

Ok | Cancel | Help | o

Add... Options. .. |0 Balete Press Options
| |
_ckse | _teb_| Press Help to learn more about the |
element.
ANSYS Example0300 9
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Example — Real Constants

No Real Constants are necessary for pure 3D solid models!

ANSYS Example0300
Computational Mechanics, AAU, Esbjerg
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0300 11
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter 210000 |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter 0.3
B Poisson’s ratio
Temperatures
EX
PRXY ] 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0300
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Siz: T
VOLUMES

® i+ Pick { Unpick TYPE NUM

(o Single " Box

" Palygen " Cirele

" Loop
TR
Select/Pick pacmm =
Lines to T T
specity & rme ot Tooms
mesh size e
for
| Select the indicated lines
0K @ IFELY
e WEREen
pick All|  Help

Press OK when finish with selection

ANSYS Example0300 13
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Ii\ Element Sizes on Picked Lines
[LESIZE] Element sizes on picked lines

SIFE Element edge length

[

MDY  Mo. of element divisions

(MDIV is used only if SIZE is blank or zero)
KYNDIV SIZE,NDIV can be changed ¥ Yes

SPACE Spacing ratio

ANGSIZ Division arc (degrees)

|

( use ANGSIZ only if number of divisions (NDIV) and
element edge length (SIZE) are blank or zero)

Clear attached areas and volumes I Mo

oK | Apply | Cancel | Help |

,—‘ Enter 2 —

Press OK when finish with selection

ANSYS Example0300 14
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AMNSYS Main Menu

Example - Meshing

Preprocessor > Meshing > Mesh > Volumes > Mapped > 4 or 6 sided

AMNSYS Main Menu

AMNSYS Main Menu

@|

Preferences
E Preprocessor
Element Type
Real Constants
Material Props
Sections
Modeling
B Meshing
Mesh Attribute
MeshTool
Size Cntrls
Mesher Opts
Concatenate
B Mesh
A Keypoints
2 Lines
Areas
[SRvolumes
Mapped
# Free
Yolume Swel
Tet Mesh Frc
Interface Me
Modify Mesh
Check Mesh
Clear
Checking Ctrls

B

Preferences
Preprocessor
Element Type
Real Constants
Material Props
Sections
Modeling
B Meshing
Mesh Attributes
MeshTool
Size Cntrls
Mesher Opts
Concatenate
B Mesh
A Keypoints
2 Lines
Areas
B Yolumes
=
&1 4 to 6 sided
Concatenaty
Del Concats
# Free
Yolume Sweep
Tet Mesh From
Interface Mesh
Modify Mesh

Preferences
B Preprocessor

=]

Element Type
Real Constants
Material Props
Sections
Modeling
Meshing
Mesh Attributes
MeshTool
Size Cntrls
Mesher Opts
Concatenate
B Mesh

# Keypoints

A Lines

Areas

B Yolumes

B Mapped
e
Concatenate
Del Concats
& Free
Yolume Sweep
Tet Mesh From
Interface Mesh
Modify Mesh

Numlz.lering Ctris Check Mesh Check Mesh 0K Apply
Archive Model Clear Clear
Coupling / Ceqgn Checking Ctrls Checking Ctrls n 5 T
FLOTRAN Set Up Numbering Ctrls Numbering Ctrls e s
F5I Set Up Archive Model Archive Model )
Loads Coupling / Cegn Coupling / Ceqn Pick ALl Help
Physics FLOTRAN Set Up FLOTRAN Set Up =] ®
| | L] |+
ANSYS Example0300

Computational Mechanics, AAU, Esbjerg

Mesh Yolumes

& pick@—— tnpick

o) Bingle {" Box

" Polygen {" Circle
[ Loog

Count = u}
Marximum =

Minimum = 1

Wolwu Ho. =

{¥ List of Items

- Min, Max, Inc

Select individual
volumes to be
meshed

NB: It is often
necessary to “Clear”
the model for
example if Element
Type or model
geometry is to be
changed

Select all volumes
defined to bhe meshed

15



Example — 3D Mesh

' ANSYS

ELEMENTS
FEE 11 Z004
09:17:42

ANSYS Example0300
Computational Mechanics, AAU, Esbjerg




Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0300.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0300 17
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Areas

Apply U,ROT. Select All DOF to fix/clamp the beam
* pick @——tmpick I\ Apply U,ROT on Areas ' Xl
o Sl M Eo S | t Ar [Da] Apply Diaplacements.{U,ROT} on Areas :

C olygon ¢ cidele elec ea Lab2 DOFs to be constrained || DOF
{ Loop A6 Or the Ieft
Gims O O end area
Maximuam = =
Minimum = 1
Area No. =
{¥ List of Items Al DoF
" Min ax nc
St Apply as ICDnstant value j

|| If Constant value then:

WallE  Displacement value I
0E @ PN o
4 .J Apply | Cancel | Help |
Reset Cancel

Pick All Help

— Press OK

ANSYS Example0300 18
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes

* pick O&—tmpicE

Note: If the model is remeshed all loads will be deleted with the element nodes

v Single {~ Box

" Polygon " Circle

[ Loop

I
[}

Count
Maximuam 171
Minimuam

Node Mo.

[} [} ]
=

{¥ List of Items

- Min, Max, Inc

1 )
ELEMENTS ANSYS

FEE 11 z004

Select indicated element node

0E @ Eprprier
Reset Cancel
Pick A1l Help
ANSYS

Press OK

Example0300 19
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Nodes

ANSYS
Computational Mechanics, AAU, Esbjerg

Change to FY

I\ Apply F/M on Nodes | %]

[F] Apply ForceMoment on Maodes
Lab  Direction of force/marm

dpply as Fx e =

If Constant value then: [Fz

YALUE  Forcefmoment value
[Help |

(a4 OJ Apply Zancel

—

Press OK to finish Enter -100

Example0300 20



Example - Save

! ANSYS

FEE 11 2004

09:34:55

ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

!

ANSYS Example0300 21
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

b Example0300
Computational Mechanics, AAU, Esbjerg




Example - Solve

Press Close
\i‘) Solution is done!
Press here
to Close
:
I\ /STATUS Command ' x|
File
SOLUTION OPTIONS
PROBLEH DIHENSIONALITY. » « « v v v v v v v s 3D
DEGREES OF FREEDI. . . . . . Wz
Ay G STRTIC (STEADY-STATE)
LOAD STEP DPTIONS
LORD STEP WUHBER. . . » o v v ooee e e e 1
TIHE AT END OF THE LOAD STEP. . . . o o . .. . 1.0000
NUHBER OF SUBSTEPS. . . . . . . oovovs oo 1
STEP CHNGE BOURDARY CcOMDITING . . . . . i
PRINT OUTPUT CONTROLS - . . .« v oo v e oo HO PRINTOLT
DRTHBSE OUTPUT CONTROLS, - Ll ALL DATA HRITTEN
FiR THE LAST SUBSTEP
ANSYS Example0300 23
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0300 24
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Example - PostProcessing

— Read Maximum displacement: DMX

ANSYS Example0300
Computational Mechanics, AAU, Esbjerg
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/

Example — Clear & Start New

Clear & Start Mew ...
iChange Jobname ...
Change Directory ...
iChange Title ...

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Fesume Jobname.db ...

Fesume fram ...

Save as Jobname.db
Save as ...
Write DB log file ...

Read Input from ...
Switch Cutput to

List
File Cperations

ANSYS File Options ...

Import
Export ...

Feport Generatar ...

Exit ...

S .
You can include commands to be

executed when the program starts up in ——
the start71.ans file.

fi\Clear Database and Start New X|

[/CLEAR] Clear database and start new!
Read start. ans after clear?

" Do not read file

Ok | Cancel | Help |

Clears (zeros out) the database stored in
memory. Clearing the database has the same
effect as leaving and reentering the ANSYS
program, but does not require you to exit.

Example0300 26

Computational Mechanics, AAU, Esbjerg



Example — Comments/Questions

 What did change compared to the Beam
model?

 The “example0300.lgw” can be edited In
“Notepad”

e What are the assumptions in this case?

« Will the shape or the number of elements
affect the solution?

ANSYS Example0300
Computational Mechanics, AAU, Esbjerg
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