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Example — Plate with a hole
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Objective: 4 = _ 2
Determine the maximum stress in the x-direction for E _ %1§OOON/mm
point A and display the deformation figure S

Tasks: a =200mm

How should this be modelled? b =100mm
Compare results with results obtained from norm t=10mm
calculations? r=210mm

- 2
Topics: o = 100N/mm

Element type, Real constants, modeling, plot results,

output graphics
ANSYS Example0240
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0240 e Command line entry
| Enter: Example0240

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Plate with a hole
ftitle, Plate with a hole
x|
[/TITLE] Enter new title || °
0] Cancel Help
ANSYS Example0240 3
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Example — Areas Rectangle

Preprocessor > Modeling > Create > Areas > Rectangle > By Dimensions

Create an area given by X=(0,100) and Y=(0,50)

AMSYS Main Menu

'references
reprocessor
H Element Type
H Real Constants
H Material Props
1 Sections
3 rodeling
B Create
Keypoints
Lines
B Areas
Arbitrary
B Rectangle

Z By 2 Corners
# By Centr & Cornr

By Dimensions

Circle
Polygon
1 Area Fillet
Yolumes
Nodes
Elements
Contact Pair
Piping Models
Circuit
Racetrack Coil
Transducers
Dperate
Mowve / Modify
Copy
Reflect
Check Geom
Delete

Cyclic Sector
[ T

[

[RECTMG] Create Rectangle by Dirmensions
¥1,¥2 ¥-coordinates

1,%2 Y-coordinates

(]34 QJ Apply | Cancel |

[\ Create Rectangle by Dimensions _

Enter O or
leave empty

Enter 100

Help |

— Press OK

Note: Keypoints (4 kp’s) and lines
(4 lines) are automatically generated

(also numbered automatically)

Example0240
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Enter O or
leave empty

Enter 50



Example — Areas Rectangle

il

AREAS

TY¥FE HUM
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Create an area given by (X,Y)=(0, 0) and Radius=10

Example — Areas Circle

Preprocessor > Modeling > Create > Areas > Circle > Solid Circle

ANSYS Main Menu

3|

Preferences
El Preprocessor

Element Type
Real Constants
faterial Props
Sections
H Modeling
Bl Create
Keypoints
Lines
B Areas
Arbitrary
Rectangle
B Circle
P
# Annulus
A1 Partial Annulu
#1 By End Points
By Dimensions

Polygon
#1 Area Fillet
Yolumes
Nodes
Elements
Contact Pair
Piping Models
Circuit
Racetrack Coil
Transducers
Operate
Wove / Modify
Copy
Reflect
Check Geom

—o-

« ' I_>Ij

a

Corﬁpljtational Mechanics, AAU, Esbjerg

li\solid Circular

¥ Pick " Unpick

x|

Up X

¥

Globhal X
¥
Z

Up X I

up ¥ I

Radius I

0K o

Apply |

Cancel |

|
Rezet I
Help I

Note: Keypoints (4 kp’s) and li
(4 lines) are automatically gen
(also numbered automatically)

Examp

nes
erated

le0240

Enter 10

Press OK



Example - Area

b s ANSYS

FEE 11 2004
10:07:232

ARELS

T¥PE NUM
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Example - Operate

Preprocessor > Modeling > Operate > Booleans > Subtract > Areas
Create the final area by subtracting the circular area from the rectangular area

AMSYS Main Menu

®|

1 Preferences
| Preprocessor
Element Type
Real Constants
Ivlaterial Props
Sections
= Modeling
Create
B Operate
Extrude
Z Extend Line
E Booleans
Intersect
Add
Bl Subtract
A Yolumes
P eas!
& Lines
With Options
Divide
Glue
Overlap
Partition
Settings
Show Degeneracy
Scale
Calc Geom Items
Move / Modify
Copy
Reflect
Check Geom
Delete
Cyclic Sector
Genl plane strn
|-— X} . —

[ [+

-

=l

Subtract Area

% pick @ i ck

v Bingle i Box

Note: Bottom left corner of ANSYS GUI

| T45BA1 Pick or enter hase areas fram which to subtract

" Polygon {" Circle
- Loop

1]
e}

Count
Maximum

Minimum

Area No.

{* List of Items

[ Min, Max, Inc

Select the rectangular area and press OK

L Note: Bottom left corner of ANSYS GUI

| Pick ar enter areas to be subtracted

Select the circular area

0E @ Sk
Beset Cancel
Press OK
Pick All Help
Example0240 8

ics, AAU, Esbjerg



Example — Areas

g ANSYS

FEE 11 2004
10:17: 56

AREAS

TYFE NUM

ANSYS Example0240
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

l\Library of Element Types ] x|
Defined Element Types: n FEl i
NOMNE DEEINED ibrary of Element Types SU’uct_Jra!I Mass 5= Snode 183
Link | Bnode 82
Bearm Triangle Gnode 2
Fipe Axi-har 4node 25

Snode 83

Element type reference number

04 | Aoy | Cancel |

Triangle 6node 2

Help |

Add... |e Sptions- Selete Press Add

Clase | Help |

ANSYS Example0240
Computational Mechanics, AAU, Esbjerg
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

Defined Element Types:

Select Plane strs w/thk

IPLANEZ element type options x|

Options for PLAKEZ, Element Type Ref, Mo, 1

PLANEZ

Element behavior k3 Flane stress j
Plane stress ]
Extra stress output kS Axisymmetric
Plane strain
Elerment output K Plane sirs w/fthk [

Ik | Cancel | Help |0

Add.. Belets Press Options

oo | _tep_| Press Help to learn more about the

element.
ANSYS Example0240 11
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 PLANEZ

04 ®

Cancel

Place the cursor
on the relevant
element and
press OK

Example0240

Computational Mechanics, AAU, Esbjerg
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Example - Real Constants

Preprocessor > Real Constants > Add

- Real Constants
li\Real Constant Set Number 1, for PLANE2 x|
' Defined Real Canstant Sets
Elerment Type Reference Mo, 1

Real Constant Set Mo, I h

Real Constant for Plane Stress with Thickness (KEYOPT (33=3)
Thickress THE I

® Ok | applky | Cancel | Help |

Enter 10

Edit... | Deleta |

Press Close
to finish

Press OK |

Heln |

ANSYS

Example0240 13
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0240 14
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material [ x| Enter- CI
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter:
. , .
S S Poisson’s ratio
Temperatures
Ex 210000 o
PRCY 4 N.YDefine Material Model Behavior 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
1 | » 1| | v
ANSYS Example0240

15
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Example — Free Meshing

Preprocessor > Meshing > Mesh > Areas > Free

Computational Mechanics, AAU, Esbjerg

ANSYS Main Menu ANSYS Main Menu @'
Preferences Preferences 1=
B Preprocessor B Preprocessor
Element Type Element Type
H Real Constants ® Real Constants
Material Props Material Props
Sections Sections
Modeling Modeling
= Meshing =2 Meshing
Mesh Attributes Mesh Attributes
MeshTool MeshTool
Size Cntrls Size Cntrls
Mesher Opts Mesher Opts
Concatenate Concatenate
B Mesh B Mesh
# Keypoints A Keypoints
& Lines A Lines
ERAIreas| E Areas
Mapped Mapped
& Free #
#1 Target Surf #1 Target Surf
Volumes Yolumes
Yolume Sweep Yolume Sweep
Tet Mesh From Tet Mesh From
Interface Mesh Interface Mesh L
Modify Mesh Modify Mesh
Check Mesh Check Mesh
Clear Clear
Checking Ctrls Checking Ctris
Numbering Ctrls Numbering Ctrls
Archive Model Archive Model
Coupling / Ceqgn Coupling / Ceqgn
FLOTRAN Set Up FLOTRAN Set Up
FSI Set Up FSI Set Up
Loads Loads j
4| <] [
ANSYS

Mesh Areas

% pick @ fpick

[ Bingle " Box

" Polygon {" Circle

- Loop

Count = a
Maximam =
Minjmam = 1
Area Mo. =

¥ List of Items

- Min, Max, Inc

0K Apply
Ba=set Cancel
Pick A11 Heln
L J

Select individual areas
to be meshed

NB: It is often
necessary to “Clear”
the model for
example if Element
Type or model
geometry is to be
changed

Select all areas defined
to be meshed

Example0240

16



Example — Free Mesh

: ANSYS

FEB 11 2004

ELEMENTS

ANSYS Example0240
Computational Mechanics, AAU, Esbjerg
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Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0240.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0240 18
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Lines

Apply U,ROT

% pick @& —mpick

i+ Bingle i~ EBojk

" Polygon " Cipcle

i Loop

I
]

Count
Maximuam

Minjimuam

[} ] n
=~

Line No.

{¥ List of Items

- Min, Max, Inc

Select the
bottom straight
line

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

Select UY to fix the beam in the y-direction

I\ Apply U,ROT on Lines ' X|

[OL] Apply Displacements {,ROT) on Lines
Lab2 DOFs to be constrained &l DOF
Al DoF
Apply as ICDnstant valLe j
YALUE  Displacement value I
ok @ | dpphy | Cancel | Help |

— Press OK

Example0240 19



Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Lines

Apply U,ROT

% pick @& —mpick

i+ Bingle
i Polygon
i Loop

{" Bok

{" Circle

Count
Maximuam
Minjimuam

Line No.

{¥ List of Items

- Min, Max, Inc

Select the left
straight line

0E @ PN o
Reset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

Select UX to fix the beam in the x-direction

I Apply UROT on Lines ' X|
[OL] Apply Displacements (LROT) on Lines l

Lab2 DOCFs to be constrained All DOF

Al DoF
Apply as ICDnstant valLe j
YALUE  Displacement value I
0] Ol dpphy | Cancel | Help |
— Press OK
Example0240 20



Example — Define Loads

Solution > Define Loads > Apply > Structural > Pressure > On lines

Apply PRES o

{* pich &——urp

ick

(o Single " Baoj

I\ Apply PRES on lines

[SFL] Apply PRES on lines as a ICunstant value

If Constant value then:

YALUE Load PRES walue I °®

If Constant value then:
Cptional PRES values at end 1 of line
{leave blank for uniform PRES
Yalue

= Select the
i Loop r|ght
I straight line
Maximuam = 5
Minimum = 1
Line No. = £ Enter '100
{* List of Items
- Min, Max, Inc
|
0E @ Zprpriyr
Reszet Cancel PreSS OK
Pick &1l Help to finish

Note: Pressure acts normal and

ANWERY to a surface _
Computational Mechanics, AAU, Esbjerg

————@ Ok | apply | Cancel | Help |

Example0240

21



Example - Save

g ANSYS

FEE 11 Z004
10:45:29

AREAS
TYPE NUM

o

Display of Analysis model

AMSYS Toolhar

Save the model
SoavVE_DB | RESLIM_DB ‘ QUIT | POVYRGEPH ‘ E-CAE |

!

ANSYS Example0240 22
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0240
Computational Mechanics, AAU, Esbjerg




_ i ) Solution is done!

Example - Solve

Press Close

Press here
to Close
X|
File
SOLUTION OPTIODHS
PROBLEH DIHEMSIOMALITY. . & & v v @ & & & & = o« 2-0
[EGREES OF FREEDOH. . . . . . s Uy
AHALYSIS TYPE & v @ v v f v e e v e on e om s STHTIC [STEADY-STHTE]
LOAD STEP OPTIOHS
LOAD STEP HUHBER. . & v @ v & ¢ & &« & & o s = » 1
TIHE AT EMD OF THE LOAD STEP. . . . . . . . .. 1.0000
HUHBERE OF SUBSTEPS. & & @ v & ¢ & @ & & o s = » 1
STEP CHAWGE BOUMDARY COMDITIOMS . . . . . . . . HO
PRINT OUTPUT COMTROLS & &« v & v & @ & & o s = & HO PRINTOUT
DATABASE OUTPUT COMTROLS. . . . . . &« & o .« . . ALL DATA HRITTEM
FOR THE LAST SUBSTEF
ANSYS Example0240 24
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0240 25
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Example - PostProcessing

= ANSYS

DISPLACEMENT
FEE 11 2004

10:48: 56

3TEP=1
3UE =1
TIME=1

DMX =.05017

— Read Maximum displacement: DMX

ANSYS Example0240
Computational Mechanics, AAU, Esbjerg
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Example — Contour Plot

General Postproc > Plot Results > Contour Plot > Nodal Sol

I Contour Nodal Solution Data X
[FLMNSOL] Cortour Modal Solution Data SeIeCt Stress

Item,Comp  Item to be contoured

2 drecton <z | Select SX for stresses in

W-shear  SXY

vZ-shear  5YZ = X'd|reCt|0n

KUND  Tterns to be plotted

& Def shape only

" Def + undeformed
" Def + undef edge

Fact Optional scale factor I 1

[/EFACET] Interpolation Modes

&+ Corner only
" Carner + midside

 all applicable

[AWPRIN] Eff MU for EQV strain |

CK, | Apply | Cancel | Help |

ANSYS Example0240 27
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Example — Contour Plot

o ANSYS

FEE 11 2004
10:51:28

NODAT, S0C0LUTION

ANSYS Example0240
Computational Mechanics, AAU, Esbjerg
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Example — Comments/Questions

e Change the element size and rerun?

 The “example0240.lgw” can be edited In
“Notepad”

 What are the assumptions in this case?

« Will the shape or the number of elements
affect the solution?

ANSYS Example0240
Computational Mechanics, AAU, Esbjerg
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit.., Example0240

Computational Mechanics, AAU, Esbjerg
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