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Example — Cantilever beam

I F

7

X

d L »
Objective: E = 210000N/mm?
Compute the maximum deflection and locate v =03
point of maximum deflection L =2100mm
Tasks: a=10mm
How should this be modelled? b=10mm
Compare results with results obtained F = 100N
from beam theory?
Topics:

Element type, Real constants, modeling,
Plot results, output graphics
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Modelling considerations

* As you begin your model generation, you will (consciously or
unconsciously) make a number of decisions that determine how you
will mathematically simulate the physical system:

What are the objectives of your analysis?
Will you model all, or just a portion, of the physical system?
How much detail will you include in your model?

What kinds of elements will you use? How dense should your finite
element mesh be?

* In general, you will attempt to balance computational expense (CPU
time, etc.) against precision of results as you answer these
guestions.

 The decisions you make in the planning stage of your analysis will
largely govern the success or failure of your analysis efforts.

ANSYS
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Modelling considerations

* Linear or Higher Order Elements

 Take Advantage of Symmetry
— The axis of symmetry must coincide with the global Cartesian Y-axis.
— Negative nodal X-coordinates are not permitted.

— The global Cartesian Y-direction represents the axial direction, the
global Cartesian X-direction represents the radial direction, and the
global Cartesian Z-direction corresponds to the circumferential direction.

— Your model should be assembled using appropriate element types:

* For axisymmetric models, use applicable 2-D solids with KEYOPT(3) = 1,
and/or axisymmetric shells. In addition, various link, contact, combination,
and surface elements can be included in a model that also contains
axisymmetric solids or shells. (The program will not realize that these "other"
elements are axisymmetric unless axisymmetric solids or shells are present.)

 How Much Detalil to Include
» Appropriate Mesh Density
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0200 e Command line entry
| Enter: Example0200

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0200 5
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

IPREP7 # Keypoint number

K, General format:  x keynoint x-coordinate
K,,100,, K#X,Y,Z Y Keypoint y-coordinate
K..100.10, Z Keypoint z-coordinate
K...10, Press Apply for KP1
li\Create Keypoints in Active Coordinate Systen X| Enter 100 in the first

[K] Create Keypoints in Active Coordinate Systern f|e|d and

NPT Keypoint number I— PreSS App|y for KP2

¥,Y,2 Location in active CS | | |

Enter 100 in the first
field and Enter 10 in

Ee] | iy | e | the second field and
Press Apply for KP3
Enter 10 in the
second field and
Press Apply for KP4
|
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2 and so on.
L,1,2

L.2,3 Create Straig HINT: By clicking with the right-
L,3.4 & ik unpick hand mouse button you shift
L.4,1 S between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
e arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel
to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help
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Example - Areas

Preprocessor > Modeling > Create > Areas > Arbitrary > By Lines
Create an area bounded by line 1, 2, 3, and 4.

AL,1,2,3,4
HINT: By clicking with the right-
P hand mouse button you shift

between the Pick/Unpick

v Single { Eox

N functl_on. Thls IS indicated by
" Loop the direction of the cursor
Count = 0 arrOW:

Maximum = 4

St Pick: upward arrow

Line Mo.

Unpick: downward arrow

{* List of Items

i Min, Max, Inc

Press OK or Cancel
! to finish selection

0K @ gk

Leset Cancel |@

/ Piglk ALL Help Exampleozoo
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

l\Library of Element Types 0

Defined Element Types:

NONE DEFINED Library of Element Types

Element type reference number

Structural Mass
Link
Beam

Cancel |

Quad 4node

drode 182
Shode 183

Shode

a2

Triangle tnode 2

Quad 4node

42

Help |

Add... |@ Esbons. Belets
Clase | Help |
ANSYS Example0200
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

PLAME4Z

x|

IPLANE42 element type options . |
Options for PLAKWE4Z, Element Type Ref, Mo, 1

Elerment caord system defined K1

Extra displacement shapes

Element behaviar
Extra stress oufput

Extra surface output

Ok |

k3

kS

K&

k2

Select Plane strs w/ithk ——

Parall to global -
| Bl

IInn: lude j

Flane stress j

Flarne stress
Axisymimetric
F'Iane strain

Cancel | Help |0

add... Dptions. .. |0 Belate

Cloze | Help |

ANSYS
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Press Help to learn more about the

element.
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 PLANE4Z

04 ®

Cancel

Place the cursor
on the relevant
element and
press OK

Example0200
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Example - Real Constants

Preprocessor > Real Constants > Add
[i\Real Constant Set Number 1, for PLANE42 . X Red =

Defined Real Constant Sets

Elerment Type Reference ha. 1

Feal Constant Set Mo, I 1

Real Constant for Plane Stress with Thickness (KEYOPT(3=3)
Thickness THEK 0

i/ 04 | dpphy | Cancel Help |

N

Edit... | Delate |
Press Close
to finish Help |
Press OK |
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0200 13
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material [ x| Enter- CI
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter:
. , .
S S Poisson’s ratio
Temperatures
Ex 210000 o
PRCY 4 N.YDefine Material Model Behavior 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
1 | » 1| | v
ANSYS Example0200
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——o

Select/Pick
Lines to

specify
mesh size
for

Pick the two
longest lines

ANSYS
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size

{* pick - Tnpick

(o Single " Box

" Palygen " Cirele
- Loop

1]
]

Conart
Marimuam

Minjimuam

noounon
= =

Line MNo.

{¥ List of Items

- Min, Max, Inc

0g @ ERp L
Beset Cancel
Pick A1l Halp

fi\ Element Sizes on Picked Lines x|
[LESIZE] Element sizes on picked lines
SIFE Element edge length I
NDIV  Mo. of element divisions I 5|
(MDIV is used only if SIZE is blank or zero)
KYNDIV SIZE,NDIV can be changed ¥ Yes
SPACE Spacing ratio I
ANGSIZ Division arc (degrees) I
( use ANGSIZ only if number of divisions (NDIV) and
element edge length (SIZE) are blank or zero)
Clear attached areas and volumes I Mo
oK | Apply | Cancel | Help |
Press OK when finish with selection
Example0200 15




Example - Meshing

Preprocessor > Meshing > Mesh > Areas > Mapped > 3 or 4 sided
®| |
Select individual areas

AMNSYS Main Menu ANSYS Main Menu AMNSYS Main Menu

Preferences
E Preprocessor

Preferences
E Preprocessor

Preferences
B Preprocessor

Element Type Element Type Element Type _
Real Constants Real Constants Real Constants * pick@——tmpick to be meshed
Material Props Material Props Material Props
Sectiu_ns Sectiu_ns Sectiu_ns * Single e
Modeling Modeling Modeling
E Meshing B Meshing B Meshing " Tolygonm ¢ Cirele
Mesh Attribute: Mesh Attributes Mesh Attributes . )
MeshTool MeshTool MeshTool N B . It IS Often
Size Cntrls Size Cntrls Size Cntrls '
Mesher Opts Mesher Dpts Mesher Opts Count = 0 0 n
Concatenate Concatenate Concatenate Maximum = 1 necessary to Clear
B Mesh B Mesh 2 Mesh
# Keypoints A Keypoints A Keypoints Minimum = 1 the mOdel for
& Lines A Lines # Lines .
Area No. =
o 8 Areas 5 Areas el example if Element
Mapped =i B Mapped
2 Free #1 By Corners 21 By Corners Ol hen Gf Tetme Type or mOdeI
#1 Target Sur 213 or 4 sided P2
Volumes Concatenate Concatenate

Yolume Swee

Tet Mesh Fro

Interface Me:
Modify Mesh
Check Mesh
Clear

Del Concats
& Free
A Target Surf
Yolumes
Volume Sweep
Tet Mesh From

Del Concats

# Free

- Min, Max, Inc

A Target Surf ||

Yolumes
Yolume Sweep
Tet Mesh From

Computational Mechanics, AAU, Esbjerg

geometry is to be
changed

Select all areas defined
to be meshed

Checking Ctrls Interface Mesh Interface Mesh 0E Apply
Numbering Ctrls Modify Mesh Modify Mesh
Archive Model Check Mesh Check Mesh Deset CaaeD
Coupling / Ceqgn Clear Clear
FLOTRAN Set Up Checking Ctrls Checking Ctrls i
F5I Set Up Numbering Ctrls Numbering Ctrls Pl‘:k.‘a‘ll Help
Loads Archive Model Archive Model j
| | [ |+
ANSYS Example0200
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Example — Analysis Type

Write Database Log l

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0200.Igw”

k

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

oK | Cancel | Help |

ANSYS Example0200 17
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Lines

Apply U,ROT SelectLine 4 ggjlect All DOF to fix/clamp the beam
F ic . — ipilc " B
Fiek (S I Apply UROT on Lines ' X
{¥ Zingle { Eox [OL] Apply Displacements (LROT) on Lines l
" Polygon ¢ Cirele Lab2 DOFs o be constrained all DoF
i Loop
Count = 0]
Maximuam = 4
Minimuam = 1
Line Mo. =
{¥ List of Items all DOF
- Min, Max, Inc
Apply as ICDnstant valLe j
YALUE  Displacement value I
0E @ p-nz) s oK @ | Apply | Cancel | Help |
Reset Cancel
Pick All Help
— Press OK
ANSYS Example0200 18
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on |

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count

Maximum

[l [

Minimum

EeyP MNo.

{¥ List of Items

- Min, Max, Inc

Select keypoint 3

Change to FY

Fl\ Apply F/M on KPs ]
[FK] Apply Force/Moment on Keypoints

Lab  Direction of force/mom P I,:x,— T|

Apply as ICnnstant value j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

If Constant value then:

VALUE Force/moment value |-1IIIIII| [

oK Tl Apply Cancel |

Press OK to finish Enter -100

Help |

Example0200 19
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Example - Save

1
ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model
SoavVE_DB | RESLIM_DB ‘ QUIT | POVYRGEPH ‘ E-CAE |

!

ANSYS Example0200 20
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0200
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_ i ) Solution is done!

Example - Solve

Press Close

Press here
to Close
.
i1 /STATUS Command B x|
File
SOLUTIOW OPTIOHS
PROBLEM DIHEWSIOWALITY. . . . . . ... .. .. -
DEGREES (OF FREEDOH. . . . . . L4 ROTZ
AHALYSIS TYPE - o v v v e e w e e e e e STATIC (STEADY-STHTE]
LOAD STEP OPTIONS
LOAD STEF HUMBER. . . . . . v v o o v w v o 1
TIHE AT EMD OF THE LOAD STEP. . . . . . . . .. 1.0000
HUHBER OF SUBSTEPS. . . . . . . . . . . .. .. 1
STEP CHAWGE BOUMDARY COMDITIONS . . . . .. .. HO
PRINT OUTPUT COWTROLS . . . . . . o . . . . - . O PRINTOUT
DATABASE OUTPUT COMTROLS. . .+ . o v v v v - ALL DATH HRITTEH
FOR THE LAST SUBSTEP
ANSYS Example0200 22
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0200 23
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Example - PostProcessing

— Read Maximum displacement: DMX

ANSYS Example0200
Computational Mechanics, AAU, Esbjerg
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Example — Comments/Questions

 What did change compared to the Beam
model?

 The “example0200.lgw” can be edited In
“Notepad”

e What are the assumptions in this case?

« Will the shape or the number of elements
affect the solution?

ANSYS Example0200
Computational Mechanics, AAU, Esbjerg
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit... Example0200
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