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Example — Truss 2D

H Section 2

Section 1
\\

Objective:
Compute the maximum deflection
~ Tasks:
, Display the deflection figure?
Topics:
Topics: Start of analysis, Element type,
Real constants, Material, modeling, ele-
ment size for beam models, saving/restoring

Section 2

C

E = 210000N/mm?
. r=0.3

- ‘ -

L =100mm
Fy H = 120mm

ANSYS

R a=b=20mm
c=d=10mm
F=100N
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Modeling considerations

* As you begin your model generation, you will (consciously or
unconsciously) make a number of decisions that determine how you
will mathematically simulate the physical system:

What are the objectives of your analysis?
Will you model all, or just a portion, of the physical system?
How much detail will you include in your model?

What kinds of elements will you use? How dense should your finite
element mesh be?

* In general, you will attempt to balance computational expense (CPU
time, etc.) against precision of results as you answer these
guestions.

 The decisions you make in the planning stage of your analysis will
largely govern the success or failure of your analysis efforts.

ANSYS
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Modeling considerations

* Linear or Higher Order Elements

 Take Advantage of Symmetry
— The axis of symmetry must coincide with the global Cartesian Y-axis.
— Negative nodal X-coordinates are not permitted.

— The global Cartesian Y-direction represents the axial direction, the
global Cartesian X-direction represents the radial direction, and the
global Cartesian Z-direction corresponds to the circumferential direction.

— Your model should be assembled using appropriate element types:

* For axisymmetric models, use applicable 2-D solids with KEYOPT(3) = 1,
and/or axisymmetric shells. In addition, various link, contact, combination,
and surface elements can be included in a model that also contains
axisymmetric solids or shells. (The program will not realize that these "other"
elements are axisymmetric unless axisymmetric solids or shells are present.)

 How Much Detalil to Include
» Appropriate Mesh Density

ANSYS Example0150 4
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0150 Command line entry
| Enter: Example0150

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Truss 2D
ftitle, Truss 2D
x|
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0150 )
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY G format: 1 Keypoint number.
K, enerallormat.  x Keypoint x-coordinate
K..100,, K#,X,Y,Z Y Keypoint y-coordinate
K. 120 Z Keypoint z-coordinate
Press Apply for KP1
Ii\Create Keypoints in Active Coordinate Systen x| Enter 100 in the first
[K] Create Keypoints in Active Coordinate System f|e|d aﬂd
i TRt I—. N Press Apply for KP2
},0,2 Location in active CS5 I [ I I Enter 120 in the
second field and
Ces ] T | Sy e R Press Apply for KP3
|
ANSYS Example0150 6
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Example - Numbering

Utility Menu > PlotCtrls > Numbering Switch on Keypoint numbers
Fan Zoom RFotate ...
View Settings b Fi\Plot Numbering Controls |
Numbering ... [/FNUM] Plot Numbering Controls
Symhbals .. KF  Keypoint numbers ¥ on
Style ?
LIME Line numbers [ off
Fomt Contrals »
Window Controls » AREA  Area numbers [ off
Erase Options >
YOLU Valume numbers [C off
Animate 4
e , MOCDE Mode numbers [ off
Device Options .. R Elem / attrib numbering INI:I numbering j
Redirect Plots i TA4BN Table Marmes I~ off
Hard Copy 4
R SWAL Mumeric contour values [~ off
G P g [MUM] Mumbering shown with ICDIDrs & numbers j
Reset Plot Cirls

=
Capture Image .. [/REPLOT] Replot upon Ok Aapply: IREpl':'t j

Festore Image ...

Write Metafile * (]34 QJ Apply | Cancel | Help |

Multi-Flot Controls .. Press OK

ML lt-vindowr Layout ...

/ Best Quality Image r ExampleOlSO 7
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2 and
Create a line between Keypoint 2 and Keypoint 3.

L,1,2 HINT: By clicking with the right-
L.2,3 ® pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
e arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel
to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help

ANSYS Example0150
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
Defined Element Types: ml‘lbrar? of Element Types x|
Library of Element Types SR UEHIEa MSes
Lirk plastic 23
tapered 54
Fipe 30 finite strain
Rigid 2 node 188 -
Solid
Shell ;I 2D elastic 3

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptions- Selete Press Add
Clase | Help |
ANSYS Example0150 9
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

x|

Add... Options... |0 Belete

IBEAMS element type options ]

Cptions for BEAMS, Element Type Ref, Mo, 1

Member force + mament output K&

Output at extra intermed pts K9 IN.;. inter med pts j

Load offset in terms of K10

Ik |

ILengﬂﬂ Lnits j

Cancel | Help |0

Close |

Press Options

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 BEAMI

Place the cursor
on the relevant
element and
press OK

[ L= =]

Example0150
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Example - Real Constants

Preprocessor > Real Constants > Add

lReal Constants for BEAMS3

Element Type Reference Mo, 1
Real Constant Set Mo,

“E

Cross-gectional area AREA

Area moment of inertia 77

400

Real Constants

Defined Real Constant Sets

X

133333 Press Close
Total beam height HEIGHT A .
- 20 to finish
Shear deflection constant SHEARZ I
Initial strain ISTEM I
Added mass/unit length  ADDMAS I
oK Apply Cancel | Help | Edit... | Delete |
®
Cloze @ HI::II_I
Press OK
ANSYS Example0150 12
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Example - Real Constants

Preprocessor > Real Constants > Add

lReal Constants for BEAMS3

Element Type Reference Mo, 1
Real Constant Set Mo,

“E

Cross-gectional area AREA

Area moment of inertia 77

100

Real Constants

Defined Real Constant Sets
Set 1

Set

x|

[B33.33 Press Close
Total beam height HEIGHT |1|:| -
’ to finish
Shear deflection constant SHEARZ I
Initial strain ISTEM I
Added mass/unit length  ADDMAS I
(4 Apply Cancel | Help | ...... A 'j'jl Edit... | Delete |
®
Close @ Halo
Press OK
ANSYS Example0150 13
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0150 14
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material [ x| Enter- CI
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter:
. , .
S S Poisson’s ratio
Temperatures
Ex 210000 o
PRCY 4 N.YDefine Material Model Behavior 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
1 | » 1| | v
ANSYS Example0150
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Example — Mesh Attributes

Preprocessor > Meshing > Mesh Attributes > Line Attributes > Picked Lines

Line Attribute

% pick @ Hmpick

i+ Bingle i~ Box

" Polygon {" Circle
i Loop

Count
Maximuam

1
z
Minimam 1
1

Line No.

{¥ List of Items

- Min, Max, Inc

0E @ Apply

Deset Cancel

Pick All Help
ANSYS—— Press OK ——

Select Line 1

li\Line Attributes _ X|

[LATT] Assign Atributes to Picked Lines

MaT  Material number -

REAL Real constant set nurmber I i d

TYFE Element type number I 1 BEAM3 j
SECT Element section IN':'”E defined j
Pick Crientation Keypoint(s) [ Mo

4 | dpphy | Cancel | Help |

Example0150 16
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Example — Mesh Attributes

Preprocessor > Meshing > Mesh Attributes > Line Attributes > Picked Lines

Line Attribute

% pick @ Hmpick

i+ Bingle i~ Box

" Polygon {" Circle
i Loop

Count
Maximuam

1
z
Minimam 1
1

Line No.

{¥ List of Items

- Min, Max, Inc

0E @ Apply

Deset Cancel

Pick All Help
ANSYS—— Press OK ——

Select Line 2

li\Line Attributes _ X|

[LATT] Assign Atributes to Picked Lines

MAT  Material number I 1 j

REAL Real constant set nurmber m

TYFE Element type number I 1 BEAM3 j
SECT Element section IN':'”E defined j
Pick Crientation Keypoint(s) [ Mo

4 | dpphy | Cancel | Help |

Example0150 17
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size fiY Element Sizes on Picked Lines x|

E— & i [LESIZE] Element sizes on picked lines
SIFE Element edge length

(o Single " Box

|

MDY  Mo. of element divisions [
" Palygen " Circle
" Loop (MDIV is used only if SIZE is blank or zero)
. KYNDIV SIZE,NDIV can be changed v Yes
Conart =
. g _ SPACE Spacing ratio I
Select/Pick Baainam s L
Minjimum = 1
LineS tO T ANGSIZ Division arc (degrees) I
ine @m. =
Specify ( use ANGSIZ only if number of divisions (NDIV) and
h . {* Lizt of Items element edge length (SIZE) are blank or zerao)
mesn size
" Min, Max, Inc Clear attached areas and volumes [ Mo
for
TS m— Ok | Apply | Cancel | Help |
Reset Canpel |
Pick ALL Hellp |
— Press OK when finish with selection Enter 1 —
ANSYS Example0150 18
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking

Count = I

Maximam

Minimam

Line Ho.

NB: It is often necessary to “Clear” the model for
R example if Element Type is to be changed

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS

Example0150 19
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Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0150.Igw”

k

" Modal

" Harmonic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oK @& Eateel Help |

ANSYS Example0150 20
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Apply U,ROT Select keypoint 1
¥ pick @ #npick
Select UX
v Single {" Box
ol LA I Apply U,ROT on KPs x|
£ Leoe [CK] Apply Displacements (U,ROT) on Keypoints
Count = 0 LabZ DOFs to be constrained Al DihF
Mzzxi = 2 Ly @
Minimam = 1 ROT?
FeyP Ho. =
{* List of Items Apply as ICDnstant value j

If Constant value then:

YALUE  Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? [~ Mo
R :‘:pplx Ok .J apply | Cancel | Help |
Heset Cancel
Pick All Help
— Press OK
ANSYS Example0150 21
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 3

¥ pick &— Trpick

Select UX and UY —

v Single {" Box

P e e - I\ Apply U,ROT on KPs t x|
< Loy [CK] Apply Displacements (U,ROT) on Keypoints

Count = 0 Labz DOFs to be constrained all D'ZIF

Meaximum = Z Ei °

Minimum = 1 ROTZE

FeyP Ho. =

{* List of Ttems Apply as ICDnstant valle j

If Constant value then:

YALUE  Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? [~ Mo
R :‘:pplx Ok .J apply | Cancel | Help |
Heset Cancel
Pick All Help
— Press OK
ANSYS Example0150 22
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on |

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count

Maximum

[l [

Minimum

EeyP MNo.

{¥ List of Items

- Min, Max, Inc

Select keypoint 2

Change to FY

Fl\ Apply F/M on KPs ]
[FK] Apply Force/Moment on Keypoints

Lab  Direction of force/mom P I,:x,— T|

Apply as ICnnstant value j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

If Constant value then:

VALUE Force/moment value |-1IIIIII| [

oK Tl Apply Cancel |

Press OK to finish Enter -100

Help |

Example0150 23
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Example - Save

il
ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

I

ANSYS Example0150 24
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0150
Computational Mechanics, AAU, Esbjerg




_ i ) Solution is done!

Example - Solve

Press Close

Press here
to Close
.
i1 /STATUS Command B x|
File
SOLUTIOW OPTIOHS
PROBLEM DIHEWSIOWALITY. . . . . . ... .. .. -
DEGREES (OF FREEDOH. . . . . . L4 ROTZ
AHALYSIS TYPE - o v v v e e w e e e e e STATIC (STEADY-STHTE]
LOAD STEP OPTIONS
LOAD STEF HUMBER. . . . . . v v o o v w v o 1
TIHE AT EMD OF THE LOAD STEP. . . . . . . . .. 1.0000
HUHBER OF SUBSTEPS. . . . . . . . . . . .. .. 1
STEP CHAWGE BOUMDARY COMDITIONS . . . . .. .. HO
PRINT OUTPUT COWTROLS . . . . . . o . . . . - . O PRINTOUT
DATABASE OUTPUT COMTROLS. . .+ . o v v v v - ALL DATH HRITTEH
FOR THE LAST SUBSTEP
ANSYS Example0150 26
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0150 27
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Example - PostProcessing

— Read Maximum displacement: DMX

ANSYS Example0150
Computational Mechanics, AAU, Esbjerg
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Example — Comments/Questions

* Try Link elements instead of beam
elements?

 The “example0150.lgw” can be edited In
“Notepad”

 Will the number of elements affect the
solution?

ANSYS Example0150 29
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File menu

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Clear & Start Mew ... —
Change Jobname ... You can include commands to be
Change Directory ... executed when the program starts up in ——
izh Title ... .
i the start71.ans file.
BESTE dotaaine al li\Clear Database and Start New
Resume fram ...
Save as Jobname.db [/CLEAR] Clear database and start nemw!
Save as .. Bec stark s gl Lo L
Write DB log file ... @ Read file
" Do not read file
Read Input from ...
Switch Cutput to »
List * x| _ cancel | e |
File Operations 4
dilseile e Clears (zeros out) the database stored in
Impart : memory. Clearing the database has the same
Bt effect as leaving and reentering the ANSYS
Repart Generatar .. program, but does not require you to exit.
/  Exit... Example0150
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