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Example — Cantilever beam

|
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l | 4
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: L = ) d
1#
Objective: E = 210000N/mm?
Compute the maximum deflection v =0.3
Tasks: L = 5000mm
Create a table and compare results with results 2 = 250mm
obtained from beam theory? b = 450mm
Display the deflection figure? c=10mm
Topics: d = 20mm
Topics: Start of analysis, Element type, Real constants, o = 15mm
Material, modeling, element size for beam models, f = 350mm
saving/restoring F = 100N
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0120 ¢ Command line entry
x| Enter: Example0120

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0120 3

Computational Mechanics, AAU, Esbjerg



Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY G T . # Keypoint number
Ko, eneral format:  x Keypoint x-coordinate
K,,5000,, K#X,Y,Z Y Keypoint y-coordinate

K,,,50, Z Keypoint z-coordinate

Enter 0,0,0 and

Press Apply
Enter 5000,0,0 and
Press Apply
Enter 0,50,0 and
i\ Create Keypoints in Active Coordinate Syster X| Press Ap p |y
[K] Create Keypaints in Active Coordinate System
NPT  Keypoint number I
¥,v,Z Location in active CS | | P
Note: An empty box
result in a zero. It is
| CGI ILEI HEIH
_ o | Loy e — a allowed to enter 0.0
in each box.
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Example - Numbering

Utility Menu > PlotCtrls > Numbering Switch on Keypoint numbers
Fan Zoom RFotate ...
View Settings b Fi\Plot Numbering Controls |
Numbering ... [/FNUM] Plot Numbering Controls
Symhbals .. KF  Keypoint numbers ¥ on
Style ?
LIME Line numbers [ off
Fomt Contrals »
Window Controls » AREA  Area numbers [ off
Erase Options >
YOLU Valume numbers [C off
Animate 4
e , MOCDE Mode numbers [ off
Device Options .. R Elem / attrib numbering INI:I numbering j
Redirect Plots i TA4BN Table Marmes I~ off
Hard Copy 4
R SWAL Mumeric contour values [~ off
G P g [MUM] Mumbering shown with ICDIDrs & numbers j
Reset Plot Cirls

=
Capture Image .. [/REPLOT] Replot upon Ok Aapply: IREpl':'t j

Festore Image ...

Write Metafile * (]34 QJ Apply | Cancel | Help |

Multi-Flot Controls .. Press OK

ML lt-vindowr Layout ...

/ Best Quality Image r ExampleOlZO 5
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2.

L,1,2

ANSYS

Create Straig HINT: By clicking with the right-
@ Pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
S O arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel

to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types . x|
Defined Element Types: mLibraW of Element Types X
NONE DEFINED Only structural element types are shawn
Library of Element Types Structural Mass Al 2node 133 -
Link 3node 189
D elastic 4

Pipe lastic 24
Rigid
Solid
Shell || tepered 44

Element type reference number

04 | Aoy | Cancel Help |

|

Add... |e Sptians: Selete Press Add
Clase | Help |
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

Defined Element Types:

BEAM44

Press Options

add... Dptions. .. | [ Belate
Cloze | Help |

ANSYS Example0120
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Example - Element Type

Preprocessor > Element Type > Add/Edit/Delete

I\BEAM44 element type options ] x|
Cptions for BEAM44, Element Type Ref. Mo, 1
Selection
Mernber force + morment output K6 IE}{clude output j
Output at extra intermed pts K9 IND intermed pts j
oxdoffst s of (49 onghuwic I8 Press Help to learn more about the
Stiffness release atnode I K7 —
ROTZ r element.
ROTY r
ROTX r
Uz r
e r
s r
Stiffiess release atnode 1 K&
ROTZ r
ROTY r
ROTH r
Uz r
Uy r
U r
(04 | Cancel | Help |.
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material [ x| Enter- CI
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter:
. , .
S S Poisson’s ratio
Temperatures
Ex 210000 o
PRCY 4 N.YDefine Material Model Behavior 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
1 | » 1| | v
ANSYS Example0120
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AMNSYS Main Menu

3|

1 Preferences
1 Preprocessor
Element Type
Real Constants
Material Props
B Sections
Section Library
B Beam
Custom Sectns
Plot Section
Sect Control
Shell
Pretension
List Sections
Delete Section
Modeling
Meshing
Checking Ctrls
Mumbering Ctrls
Archive Model
Coupling / Ceqgn
FSI Set Up
Loads
Physics
Path Operations
| Solution
| General Postproc
1 TimeHist Postpro
| Topological Opt
| ROM Tool

1 Nacinn Mat

K8 [ +]

-

El

ANSYS

B Beam Tool

Example Section

- L— Enter i253

— Select the | profile

Follow the
guidelines at Enter
the appropiate
cross-sectional
data

1D |1
Name I o—
Sub-Type T vl
[ ] L
Offset To -l
&
Offset-Y ']
Offset-Z % P
-
12w L
s I
=
t1 —
W Ed
We ||]
W3 ||]
t1 ||]
t2 ||]
t3 ||]

0
TEE
Coarse Fine
0K @———#ppty—]|

Close | Preview |
Help | Meshview |

Press OK to finish

Example0120
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B Beam Tool

X

ID |17
Name Ii
Sub-Type II—;,
Oftset To Im
OffsetY ||17
OffsetZ |07
2 w2
NE 2
Fib— i
W1 250
W2 450
W3 350

t1
t2

1

i3

—h
=

iR N

Coarse Fine

0K | Apply |
Close | Preview |
Help | Meshview |




Example — Line Attributes

Preprocessor > Meshing > Mesh Attributes > Picked Lines

llLine Attributes K
[LATT] Assign Atlributes to Picked Lines

MAT  Material number =

REAL Real constant set number IN':'”E defined j

TYPE Element type number I 1  BEAMdd j
SECT Elerment section I 1 253 jo—

Pick Crientation Keypaint{s)

™ Mo @———

ok @ Aoy |

Cancel |

Help |

ANSYS

— Press OK to finish

Change to Yes

Select KP3 —

7l Select section 1253

Line Attribute

% pick - Tnpick

oy Zingle {0 Box

) Eolyoon {0 Cirole
i Lioap

n
o}

Count
Maximam

Minimum

1] n 1]
—

EeyP Ho.

{* List of Items

(" Min, Max, Inc

Example0120
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Reszet Cancel
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines
fi\ Element Sizes on Picked Lines x|

E— & i [LESIZE] Element sizes on picked lines
SIFE Element edge length

(o Single " Box

|

MDY  Mo. of element divisions [
" Palygen " Circle
" Loop (MDIV is used only if SIZE is blank or zero)
. KYNDIV SIZE,NDIV can be changed v Yes
Conart =
. g _ SPACE Spacing ratio I
Select/Pick Baainam s L
Minjimum = 1
LineS tO T ANGSIZ Division arc (degrees) I
ine @m. =
Specify ( use ANGSIZ only if number of divisions (NDIV) and
h . {* Lizt of Items element edge length (SIZE) are blank or zerao)
mesn size
" Min, Max, Inc Clear attached areas and volumes [ Mo
for
TS m— Ok | Apply | Cancel | Help |
Reset Canpel |
Pick ALL Hellp |
— Press OK when finish with selection Enter 5 —
ANSYS Example0120 14
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking

Count = I

Maximam

Minimam

Line Ho.

NB: It is often necessary to “Clear” the model for
R example if Element Type is to be changed

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS

Example0120
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Example - PlotCtrls Menu

Fan Zoom Rotate ...
Yiew Settings »

Mumbering ...
Symbols ...

Hidden Line Cptions ...

I , Size and Shape ... @+
Edge Options
Window Contrals * HEh
Eraze Options * Contours ’
animate * SEaph ¢
Colors ¢
Annotation »
Light Source
Device Options ... d
Redirect Plots * T leerey '
Texturing 4
Hard Copy *
Background 4
Sawe Plot Cirls ... : :
Multilegend Cptions »

Festore Flot Cirls ...

Flaating Point Format ...
Reset Plot Cirls

Displacement Scaling ...

Capture Image ... ;
Yector Arrow Scaling ...

Festore Image ...

Write Metafile * Shell Mormals ...
Solid Model Facets ...
Multi-Plot Controls ... CHiE HIOHE! Farets
vy Symmetry Expansion 4
ML= indowe Layout ..
Best Quality Image »
ANSYS

Computational Mechanics, AAU, Esbjerg

Size and Shape x|
[/SHRINK] Shrink entities by 0 percent
[/ESHAPE] Display of element M of e
shapes based on real
constant descriptions
SCALE Real constant multiplier ID
[/EFACET] Facets/element edge I 1 facet/edge j
[[RATIO] Distortion of Geornetry
Wit Windowe number IWindDw 1 d
RATOX ¥ distortion ratio I 1
RATOY % distortion ratio I 1
[/CFORMAT] Component/Parameter Format
MFIRST, MLAST Widths |32 IEI
[/REFLOT ] Replot upon OK f&pply? IRepIDt j
(04 | Apply | Cancel | Help |
Change to On
Example0120 16




Example — Display of Element

ANSYS Example0120
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Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0120.Igw”

k

" Modal

" Harmonic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oK @& Eateel Help |

ANSYS Example0120 18
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 1

¥ pick &— Trpick

Select All DOF to fix/clamp the beam
v Single {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs X

< Loy [DK] Apply Displacements (U,ROT) on Keypoints
P - 0 Lab2 DOFs to be constrained
Maximum = 2
Minimum = 1
FeyP Ho. =
Appl
{¥ List of Items RSy o ICUHStEIﬂt value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ Ho
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0120 19
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on |

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count

Maximum

[l [

Minimum

EeyP MNo.

{¥ List of Items

- Min, Max, Inc

Select keypoint 2

Change to FY

Fl\ Apply F/M on KPs ]
[FK] Apply Force/Moment on Keypoints

Lab  Direction of force/mom P I,:x,— T|

Apply as ICnnstant value j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

If Constant value then:

VALUE Force/moment value |-1IIIIII| [

oK Tl Apply Cancel |

Press OK to finish Enter -100

Help |

Example0120 20
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Example - Save

el
ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model

SAVE_DB | FESLM_DB | QUIT | POVYEGRPH | E-CAE |

I

ANSYS Example0120 21
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0120
Computational Mechanics, AAU, Esbjerg




Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0120 23
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Example - PostProcessing

— Read Maximum displacement: DMX

ANSYS Example0120
Computational Mechanics, AAU, Esbjerg
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