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Example — Cantilever beam

Ya
p
| 1
) L

Objective: E = 210000N/mm?®
Display the moment curve v =03
Tasks: L =1000mm
Obtain values in intermediate points? a=10mm
Create an element table? b =10mm
Display the moment curve? p = 10N/mm

Topics:
Element type, pressure load, Element table/output, list
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0110 ¢ Command line entry
x| Enter: Example0110

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY . # Keypoint number
Ky, General format:  x keynoint x-coordinate
K..100 K#,X,Y,Z Y Keypoint y-coordinate
B Z Keypoint z-coordinate
I\ Create Keypoints in Active Coordinate System x|
[K] Create Keypaints in Active Coordinate System
NPT  Keypoint number l— Press Apply

¥,¥,Z Location in active CS | |

0] | fYalal | [ Earee Hed

>l Enter 100 and

[K] Create Keypaints in Active Coordinate System Pr ess Ap p |y
NPT  Keypoint number I
¥,¥,Z Location in active CS I 100 ° i i

Note: An empty box
result in a zero. It is

OK n&- | . CGI Il_l:I HEIH
4| &I —_— — | allowed to enter 0.0

in each box.
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Example - Numbering

Utility Menu > PlotCtrls > Numbering Switch on Keypoint numbers
Fan Zoom RFotate ...
View Settings b Fi\Plot Numbering Controls |
Numbering ... [/FNUM] Plot Numbering Controls
Symhbals .. KF  Keypoint numbers ¥ on
Style ?
LIME Line numbers [ off
Fomt Contrals »
Window Controls » AREA  Area numbers [ off
Erase Options >
YOLU Valume numbers [C off
Animate 4
e , MOCDE Mode numbers [ off
Device Options .. R Elem / attrib numbering INI:I numbering j
Redirect Plots i TA4BN Table Marmes I~ off
Hard Copy 4
R SWAL Mumeric contour values [~ off
G P g [MUM] Mumbering shown with ICDIDrs & numbers j
Reset Plot Cirls

=
Capture Image .. [/REPLOT] Replot upon Ok Aapply: IREpl':'t j

Festore Image ...

Write Metafile * (]34 QJ Apply | Cancel | Help |

Multi-Flot Controls .. Press OK

ML lt-vindowr Layout ...

/ Best Quality Image r ExampleOllO 5
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2.

L,1,2

ANSYS

Create Straig HINT: By clicking with the right-
@ Pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
S O arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel

to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help

Example0110
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
Defined Element Types: ml‘lbrar? of Element Types x|
Library of Element Types SR UEHIEa MSes
Lirk plastic 23
tapered 54
Fipe 30 finite strain
Rigid 2 node 188 -
Solid
Shell ;I 2D elastic 3

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptions- Selete Press Add
Clase | Help |
ANSYS Example0110 7
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

x|

Add... Options... |0 Belete

IBEAMS element type options ]

Cptions for BEAMS, Element Type Ref, Mo, 1

Member force + mament output K&

Output at extra intermed pts K9 IN.;. inter med pts j

Load offset in terms of K10

Ik |

ILengﬂﬂ Lnits j

Cancel | Help |0

Close |

Press Options

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg

element.

Example0110 8



Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 BEAMI

Place the cursor
on the relevant
element and
press OK

[ L= =]

Example0110
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Example - Real Constants

Preprocessor > Real Constants > Add

lReal Constants for BEAMS3

Element Type Reference Mo, 1
Real Constant Set Mo,

“E

Cross-gectional area AREA

Area moment of inertia 77

Real Constants

Defined Real Constant Sets

X

| Press Close

Total b height HEIGHT ..
e | to finish
Shear deflection constant SHEARZ I
Initial sirain ISTRM I
Added mass/unit length  ADDMAS I

oK Apply Cancel | Help | Edit... | Delete |

®

Close @ HI::II_I
Press OK
ANSYS Example0110 10
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0110 11
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Example - Material Properties

Preprocessor > Material Props > Material Models

: Click here
Linear Isotropic Properties for Material [ x| Enter- CI
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter:
. , .
S S Poisson’s ratio
Temperatures
Ex 210000 o
PRCY 4 N.YDefine Material Model Behavior 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
1 | » 1| | v
ANSYS Example0110
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines
fi\ Element Sizes on Picked Lines x|

E— & i [LESIZE] Element sizes on picked lines
SIFE Element edge length

(o Single " Box

|

MDY  Mo. of element divisions [
" Palygen " Circle
" Loop (MDIV is used only if SIZE is blank or zero)
. KYNDIV SIZE,NDIV can be changed v Yes
Conart =
. g _ SPACE Spacing ratio I
Select/Pick Baainam s L
Minjimum = 1
LineS tO T ANGSIZ Division arc (degrees) I
ine @m. =
Specify ( use ANGSIZ only if number of divisions (NDIV) and
h . {* Lizt of Items element edge length (SIZE) are blank or zerao)
mesn size
" Min, Max, Inc Clear attached areas and volumes [ Mo
for
TS m— Ok | Apply | Cancel | Help |
Reset Canpel |
Pick ALL Hellp |
— Press OK when finish with selection Enter 1 —
ANSYS Example0110 13
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking

Count = I

Maximam

Minimam

Line Ho.

NB: It is often necessary to “Clear” the model for
R example if Element Type is to be changed

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS

Example0110 14
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Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0110.Igw”

k

" Modal

" Harmonic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oK @& Eateel Help |

ANSYS Example0110 15
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 1

¥ pick &— Trpick

Select All DOF to fix/clamp the beam
v Single {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs X

< Loy [DK] Apply Displacements (U,ROT) on Keypoints
P - 0 Lab2 DOFs to be constrained
Maximum = 2
Minimum = 1
FeyP Ho. =
Appl
{¥ List of Items RSy o ICUHStEIﬂt value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ Ho
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0110 16
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Pressure > On Beams

Apply PRES o

% pick .—F—mﬁ@—‘

Select the line

Enter 10
o) Bingle {" Box
: x
C Dolygen [ cipele Apply PRES on Beams X]
" Loop [SFEEAM] Apply Pressure (FRES) on Beam Elements
LKEY Load key I 1
Count = u}
Maximum = 1 Yall  Pressure value at node 1 I
Minimam =1 Wall  Pressure value at node I
Elem Ho. =
{leave blank for uniform pressure)
 List of Iteus Optional offsets for pressure load
{" Min, Max, Inc IOFFST  Offset from I node I
JOFFST  Offset from 1 node I
g @ Py e
Beset Cancel W -":"-ppl':." CLEEJI Llpl
Pick A11 Help |
Press OK to finish
ANSYS Example0110 17
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Example - Save

il
ELEMENTS

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

I

ANSYS Example0110 18
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0110
Computational Mechanics, AAU, Esbjerg




Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0110 20
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Example - PostProcessing

— Read Maximum displacement: DMX

ANSYS Example0110
Computational Mechanics, AAU, Esbjerg
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Example — Element Table

AMNSYS Main Menu

AMSYS Main Menu

Preferences
Preprocessor
Solution
= General Postproc
Data & File Dpt:
Results Summal
Read Results
Failure Criteria
Plot Results
List Results
Query Results
= Options for Out
Results Viewer
Write PGR File
MNodal Calcs
=W lement Table
Define Table
Plot Elem Tah
List Elem Tab
Abs Value Of
Sum of Each !
Add Items
Multiply
Find Maximun
Find Minimum
Exponentiate
Cross Produc
Dot Product
Erase Table
Path Operation:
Load Case
Check Elem Sha
Write Results
ROM Operation:

-

J

FlimEEA

Preferences
Preprocessor
Solution
E General Postproc
Data & File Dpts
Results Summary
Read Results
Failure Criteria
Plot Results
List Results
OQuery Results
Dptions for Dutp
Results Viewer
write PGR File
MNodal Calcs
& Element Table
Plot Elem Table
List Elem Table
Abs value Option
Sum of Each Item
Add Items
Multiply
Find Mazimum
Find Minimum
Exponentiate
Cross Product
Dot Product
Erase Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Dperations

Mmoo

l

Element Table Data

Currently Defined Data and Status:

Label

WCME DEFINED

Item Comp

@ Add... |

Close |

Time Stamp

Update |

Status

Delete |
Help |

El

|

ANSYS

Computational Mechanics, AAU, Esbjerg

- Press Add

Example0110
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Example — Element Table

l\Define additional Element Table Items ' %]

[AWPRIM] Eff MU for EQY sirain I

[ETABLE] Cefine Additional Element Table [tems
Lab Liser label for item

Item,Comp Results data iem DOF solution Translation U
Stress Ly
Strain-total Uz
Strain-mech+thrm  * ||Rotation  ROTX
Modal force data ROTY -
Energy
Error estimation ;I Translation UxX

{For "By sequence num", enter sequence
nao. in Selection box, See Table 4.xx-3
in Elements Manual for seq. numbers. )

Ok, | Apply | Cancel | Helm |

ANSYS Example0110
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Example — Element Table

| Name | Definition | o | R
|EL |Element HNumber | i | by
INODES [Element nodes - I, I oY | T
|I'u'IP:.T |Element material mamber | T | ¥
|1FDLT_T: |Element wolute | H | iy
|XC, ¥ |L|:u:ati|:|n where results are reported | T | 3
TEMP Temperatures T1, T2, T3, T4 vy |
[PRES Pressure P1 at nodes L,J; OFFST1 at1,J; P2 at 1], OFFST2 at [, 1, P3 at I, P4 at ] v | T
BDIR \tuxial direct stress [ 1 || 1
|SE|‘1’T |Elending stress on the element +7 side of the beam | 1 | 1
|SEYB |Eendjng gtress on the element -¥ side of the heam | 1 | 1
|SI'u'IﬁX |I'u'I aittoan stress (ditect stress +hending stress) | 1 | 1
|SI'u'IIN |Ii-'Iin1'mmt1 stress (direct stress - bending stress) | 1 | 1
[EFELDIR \tixial elastic strain at the end [ 1 || 1
|EPELEIYT |Elending elastic strain on the element +Y side of the heam | 1 | 1
|EPELEIYB |Eendjng elastic straiti on the element -V side of the heam | 1 | 1
[EFTHDIR |tixial thermal strain at the end [ 1 || 1
|EPTHEI‘1’T |Elending thermal strain on the element +¥ side of the beam | 1 | 1
|EPTHEYB |E ending thermal strain on the element -¥ side of the beam | 1 | 1
[EPINAXL Initial axial strain in the element [ 1 || 1
|MFOR(X, Ly |I'u'I ethber forces in the element coordinate system X and ¥ direction | 2 | iy
|I'u'II'u'IDI'u'IZ |I'u'I etiber moment it the element coordinate system Z direction | 2 | T
ANSYS Example0110

Computational Mechanics, AAU, Esbjerg
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Example — Element Table

Tahle 3.2. BEAMS3 Hem and Sequence Numbers (KEYOPT(?)=0)

ETABLE and ESOL Command Irput

. |
‘ Qruiput Quantity Name | e | E | I | J
| SDIR | L3 | 5 | 1 | 3
| SBYT | L3 | | 2 | 5
| SBVE | L3 | | 3 | &
| = | LEFEL M7\BEAM3 element type options x|
| EFELEYT | LEFEL []
| EFELEYE | LEFEL [ Options for BEAMS, Element Type Ref, Mo, 1
| =T | LEPTH i Member force + moment output K&
| EFTHEYT | LEFTH []
| EFTHEYE | LEFTH [] :
| CPlAdL | = i Output at extra intermed pts K9 IN':' intermed pts d
| SMAX | NMISC [] : .
| S | = 3 Load offset in terms of K10 ILer-lgth Lhits j
| MFORS | SMISC [
| MFORY | AMIEC [ oK, | Cancel | Help |
| WMMOMZ | SMISC [
| Pl | SMISC [
| QFFST1 | SMIC | | 13 | 16
| F2 | SMIC | | 17 | 12
| OFFST2 | SMISC | | 19 | 20
| P2 | SMIAC | | 21 | =
| P4 | SMIC | | | 2
| Pseudo Node
| 1 | 2 | 3 |
| TEMP LEFE 1 | 2 | 3 |
ANSYS Example0110 25
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Example — Element Table

Element Table Data L

Currently Defined Data and Status:

Latne| Iterm Carmp Tirme Stamp Status

Time= 1.0000

Add... Update |
Close |

{Current)

Delets |
Help |

x|

ANSYS
Computational Mechanics, AAU, Esbjerg
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Example — Element Table

Element Table Data |
Currently Defined Data and Status:

Late| Iterm Carmp Tirme Stamp Status
SHISA SIS & Time= 1.0000 {Current)

Time= 1.0000 {Current)

Add... Update |

Close

Delete |

Help

x|

ANSYS Example0110
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Example — Plot Line-Element

AMNSYS Main MMenu

AMNSYS Main MMenu

®|

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
A Plot Results
Deformed Shap
=ERContour Plot
Nodal Solu
Element Solu
Elem Table
Line Elem Res
vector Plot
Plot Path Item
Concrete Plot
List Results
Query Results
Options for ODutp
Results Yiewer
Write PGR File
Modal Calcs
Element Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Operations
Submodeling
Fatigue
Safety Factor
Define,/Modify
[ .

J

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
A Plot Results
Deformed Shape
B Contour Plot
Nodal Solu
Element Solu
Elem Table
Yector Plot
Plot Path Item
Concrete Plot
List Results
Query Results
Options for ODutp
Results Yiewer
Write PGR File
Modal Calcs
Element Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Operations
Submodeling
Fatigue
Safety Factor
Define,/Modify
[ .

J

-

I_>Id

ANSYS

Computational Mechanics, AAU, Esbjerg

FAVPlot Line-Element Results _

[FLLS] Flot Line-Element Result
Labl Elem table item at node 1

Labl Elem table item at node 1
Fact Cptional scale factor

KUND Items to be plotted

Ok |

Apply |

=ylb=tal

I_|1:|

SMIS12 -

" Def shape only
% Def + undeformed
" Def + undef edge

Help

Example0110
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Example — Plot Line-Element

LINE 3TRESS ANSYS

FEE 11 Z004
22:49:06

ZTEP=1

2UB =1

TIME=1

2MIZE SMIS1Z
MIN =-50000
ELEM=1

MAX =-.546E-11
ELEM=1

ANSYS Example0110
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