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Example — Cantilever beam
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Objective:
Display the moment curve

Tasks:

Obtain values in intermediate points?
Create an element table?

Display the moment curve?

Topics:

Start of analysis, Element table/output,
intermediate points, saving/restoring
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E = 210000N/mm?®
r=0.3

L = 150mm

c = 100mm
a=10mm
b=10mm
F1=100N

F2 = 10N



Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0102 ¢ Command line entry
x| Enter: Example0102

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY . # Keypoint number

Ko, General format:  x keynoint x-coordinate
K,,100,, K#XY,Z Y Keypoint y-coordinate
K 150 Z Keypoint z-coordinate

Enter 0,0,0 and
Press Apply for KP1
Enter 100,0,0 and

I\ Create Keypoints in Active Coordinate Systen x| Press App |y for KP2
[K] Create Keypaints in Active Coordinate System

MPT  Keypoint number I— Enter 150’0’0 and

#,¥,Z Location in active CS | S i i Press Apply for KP3

| CGI ILEI HEIH
Ces ] [ [ — 2 Note: An empty box
result in a zero.
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint 1 and Keypoint 2 and so on.
L,1,2

L,2,3 Create Straig HINT: By clicking with the right-
@ Pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
i i the direction of the cursor
S O arrow:

Minimuam

EeyP Mo,

Pick: upward arrow

% List of Items UanCk downward arrOW

- Min, Max, Inc

Press OK or Cancel
to finish selection

0E @ F7) a5

Beset Cancel@®

Pick AI1 Help

ANSYS Example0102
Computational Mechanics, AAU, Esbjerg




Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete
x|

Defined Element Types: l\Library of Element Types

NONE DEFINED Library of Element Types

Element type reference number

04 | Aoy |

Structural Mass
Link

Pipe

Rigid
Solid
Shell

I 1
Cancel |

plastic
tapered
30 finite strain

2 hode

23
54

128

2D elastic

Help |

3

Add...e Estons. Berets
——— —— Press Add
Clase | Help |
ANSYS Example0102
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Example

- Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

x|

Add...

IBEAMS element type options

Cptions for BEAMS, Element Type Ref, Mo, 1

Member force + mament output K&

IE}{cIude oLt

Output at extra intermed pts KO

Load offset in terms of K10

Options... |0 Belete

Close |

ANSYS
Computational Mechanics, AAU, Esbjerg

ILengﬂﬂ Lnits j
04 | Cancel | Help |
Press Options
Change to “9 intermed pts”
Example0102 7




Example - Element Type

Notice the key option

Tahble 3.7. BEAMS Item and Sequence Numbers (KEYOPT(9)=9) @

| number for later use

‘ Ougut | SR TR | ) | BEAMS3 element type options x|
Quanity

Name | Mem | E | 1 Ml M2 | L3 |04 | IS optinng for BEAMS, Element Type Ref. No. 1

[ s | LS | [ 1+ [ 4 | 7 | w0 [ 13 16

| sBYT | 1= | [z [ 5 | & [ 1 [ 14 17 Member force + moment ouiput K6 @&———

[ sevE || LS | [ 3 [ & | o [ 12 [ 15 18

| EFELDIR | LEPEL | Lt [ 4 17 [ [ 138 [ 16 ouput atextra intermed pts K9 @———————

| EPELE¥YT | LEPEL | [ 2 [ 5 | & [ 1 | 14 17

| FPELEYE | LEPEL | - | 3 | & [ 9 [ 1z | 13 18 , .

eroR | | e 7 ol s Load offset in terms of K10 @ ILEr—,,EIﬂFI Lhits j

| EPTHEVT | LEPTH | [ 2 [ 5 | & | 1 | 14 17

[ EpTHEYE | LEPTH [ - | 3 | & [ 9o [ 1z | 13 18

[ Epmax | wePTH [ 34 [ - [ - [ - [ - [ - ] LI CLEEll ﬂ

[ smax | nwMIBC | [+ [ 2 | 5 | 7 | 9o 1

[ swmmy | wMIEC | [ 2 [ 4 | & | &8 [ w 12— , , , ,

[ mroRx | amsc | - [ 1 | 7 [ 13 [ [ 2 | an [ 3w [ @& | @ | 5 | e
.l+lm@mﬁl+lﬂ“mll+llll|ll}l+l@lIPll‘ll|lﬂ['l+lhll|lﬁil+l38llblMl*le‘l+lﬁll|l6Dll SEEEEEEEE
s | wmomz [ smusc [ - [ 6 [ 12 [ 1z [ 24 [0 [ 3 [ a4 [ a4 [ sa [ e [ 66 .
ll|llllulllll|lIMHCIll|ll_llrlﬁll|ll_ll*ll_ll|ll_llﬁll_llPl_lll|ll_ll*ll_lllll_ll1ll_llrl@llllllllllll

| oFFsTt | smmsc [ - | & | [ - [ - " ' ' : : : b

or e |- [m [ - - [ - Remember MFORX, SMISC,6...66 —

| oFFsT2 | sMisc | - [ 73 | - - . . . . . .

. P3| sMmc | [ 75 | L- - - - | L - - [ - -

[ e [ swsc | - | - I - [ - [ - -0 -0 -0 -1 -1 Press Help to launch

| | Pseudo Node .

| T R the documentation for

| TEMF | LEFE | 1 2 | 3 :

| this element type.
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Example — Real Constants

Preprocessor > Real Constants > Add
Real Constants

Defined Feal Constant Sets

MOME DEFIMED

X

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

Element Type for Real Col

Choose element type:

Type 1 BEAMI

Place the cursor
on the relevant
element and
press OK

[ L= =]

Example0102
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Example - Real Constants

Preprocessor > Real Constants > Add

Enter cross-
SeCtional data Defined Real Constant Sets

lReal Constants for BEAMS3

Element Type Reference Mo, 1
Real Constant Set Mo,

Cross-gectional area AREA

Area moment of inertia 77

Total beam height HEIGHT
Shear deflection constant SHEARZ
Initial strain ISTEM

Added mass/unit length  ADDMAS

WW :

Edit... | Deleta |

(14 Apply Cancel | Heln |

Press Close to finish ® Close | Help |

Press OK

ANSYS Example0102 10
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0102 11
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Example - Material Properties

Preprocessor > Material Props > Material Models

Linear Isotropic Properties for Material [

Linear Isotropic Material Properties for Material Mumber 1

x/| Enter: Click here
Modulus of elasticity to Close
Enter: ‘

il
Temperatures
EX 210000 ®
PRI 4

add Temperature | Delete Temperature |

OF. |

Cant

ANSYS

Computational Mechanics, AAU, Esbjerg

Poisson’s ratio

F\nofine Material Model Behavior
Material Edit Help

— Material Models Defined

& Material Model Nurnber 1
& Linear Isotropic

— Material Models Available

iz @8 Structural
|ﬁ Linear
8 Elastic

€ Orthotropic
& Anisofrapic
MNonlinear
& Density
Thermal Expansion Coef
# Darmping

(] & Friction Coefficiant
If (Zm | lemw W chmwrim] inbimune
»

o™

Example0102
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Example - Meshing

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines
fi\ Element Sizes on Picked Lines x|

E— & i [LESIZE] Element sizes on picked lines
SIFE Element edge length

(o Single " Box

[

MDIV  Mo. of element divisions o
" Polygon " Circle
" Loop (MDIV is used only if SIZE is blank or zero)
. KYNDIV SIZE,NDIV can be changed v Yes
Count =
. g _ SPACE Spacing ratio
Select/Pick T |
Minimum = 1
LineS to e ANGSIZ Division arc (degrees) I
ine @m. =
Specify ( use ANGSIZ only if number of divisions (NDIV) and
h . {* Lizt of Items element edge length (SIZE) are blank or zerao)
mesn Size
" Min, Max, Inc Clear attached areas and volumes T Mo
for
S — oK | Apply | Cancel | Help |
Reset Cancel |
Pick ALL Help |
—— Press OK when finish with selection Enter 1 —
ANSYS Example0102 13
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITRE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking
Count = 0

Maximum = 1

Minimaom = 1

Line No. =

{¥ List of Items

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS

Example0102
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Example — Analysis Type

Write Database Log :

Wiite D atabase Log to Directories:
i @ o hadminiztrator
Cancel |
= ot

| [=+ DOCUMEMNTS .&Nj Hel |
E= ADMINISTRATOI P
3 Cookies

3 Dokumenter

LI £ Foretrukne ﬂ
Solution > Analysis Type > New Analysis <t Al

IDatahase Log [ Igw] ;I I = ;I MHetwark. .. |
m New Ana I?ISis | EI I'W'rite non-ezzential cmds as comments LI

[ANTYPE] Type of analysis

File > Write DB log file
Enter “example0102.Igw”

k

" Modal

" Harmonic
" Transient
" Spectrum

" Eigen Buckling
" Substructuring PreSS OK

oK @& Eateel Help |

ANSYS Example0102 15
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint 1

¥ pick &— Trpick

Select All DOF to fix/clamp the beam
v Single {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs X

< Loy [DK] Apply Displacements (U,ROT) on Keypoints
P - 0 Lab2 DOFs to be constrained
Maximum = 2
Minimum = 1
FeyP Ho. =
Appl
{¥ List of Items RSy o ICUHStEIﬂt value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ Ho
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0102 16
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on |

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count

Maximum

[l [

Minimum

EeyP MNo.

{¥ List of Items

- Min, Max, Inc

Select keypoint 2

Select FY
Fl\ Apply F/M on KPs ]
[FK] Apply Force/Moment on Keypoints
Lab  Direction of force/mom P I,:x,— T|
Apply as ICnnstant value j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

If Constant value then:

VALUE Force/moment value I
J |

oK Tl Apply Cancel | Hel

Press OK to finish Enter -100

Example0102 17
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on |

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count

Maximum

[l [

Minimum

EeyP MNo.

{¥ List of Items

- Min, Max, Inc

Select keypoint 3

Select FY
Fl\ Apply F/M on KPs ]
[FK] Apply Force/Moment on Keypoints
Lab  Direction of force/mom P I,:x,— T|
Apply as ICnnstant value j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

If Constant value then:

VALUE Force/moment value I
J |

oK Tl Apply Cancel | Hel

Press OK to finish Enter -10

Example0102 18
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Example - Save

' ANSYS

FEE 11 z004

ELEMENTS

21:33:12

Display of Analysis model

AMEYS Toolbar

[ SAYE_DE | RESUM_DB | QUIT | POWYRGEPH | E-CAE Save the mOdel

ANSYS Example0102 19
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Example - Solve

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

pml o Solve Current LoadStep x
sty Opts Solve Current Load Step i x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

S Example0102
Computational Mechanics, AAU, Esbjerg




Example - PostProcessing

Solution > General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0102 21
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Example - PostProcessing

ANSYS

FEE 11 2004
21:35:20

DISFLACEMENT

STEF=1
SUB =1
TIME=1
DME =.397621

ANSYS Example0102
Computational Mechanics, AAU, Esbjerg




Example — Element Table

AMNSYS Main Menu

AMSYS Main Menu

Element Table Data ]

Preferences
Preprocessor
Solution
= General Postproc
Data & File Dpt:
Results Summal
Read Results
Failure Criteria
Plot Results
List Results
Query Results
= Options for Out
Results Viewer
Write PGR File
MNodal Calcs
=W lement Table
Define Table
Plot Elem Tah
List Elem Tab
Abs Value Of
Sum of Each !
Add Items
Multiply
Find Maximun
Find Minimum
Exponentiate
Cross Produc
Dot Product
Erase Table
Path Operation:
Load Case
Check Elem Sha
Write Results
ROM Operation:

-

J

FlimEEA

Preferences
Preprocessor
Solution
E General Postproc
Data & File Dpts
Results Summary
Read Results
Failure Criteria
Plot Results
List Results
OQuery Results
Dptions for Dutp
Results Viewer
write PGR File
MNodal Calcs
& Element Table
Plot Elem Table
List Elem Table
Abs value Option
Sum of Each Item
Add Items
Multiply
Find Mazimum
Find Minimum
Exponentiate
Cross Product
Dot Product
Erase Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Dperations

Mmoo

l

Currently Defined Data and Status:

Label Item Camp Titne Stamp Status

WCME DEFINED

Add...

Update | Delete |

Help |

Close |

- — Press Add to add the first data line

|

ANSYS

Example0102

Computational Mechanics, AAU, Esbjerg
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Example — Element Table

[i\\Define Additional Element Table Items ]

[AYPRIN] Eff NU for EQY sirain

Lab User label for item

[ETABLE] Define Additional Element Table tems

Item,Comp Results data item DiOF solution Translation 1K
Stress Ly
Strain-total Uz
Strain-mech+thr m T Rotation ROTX
Modal force data ROTY -
Energy
Error estimation _ﬂ Translation L

(Far "By sequence num", enfer sequence
no. in Selection box, See Table 4.xx-3

in Elerments Manual for seq. numbers. )

(814 | Apply | Cancel Help |

Scroll down in this menu to find the line “By sequence number” —

ANSYS Example0102
Computational Mechanics, AAU, Esbjerg



Example — Element Table

Fi\Define Additional Element Table Items x|

[AWPRIN] Eff NU for EQY sirain I

[ETABLE] Define additional Elerment Table Items

Lab User label for item I

Item,Comp Results data iem Strain-thermal -
Strain-plastic MMISC,
Strain-creep LS,
Strain-other LEFEL,
Contact LEFTH, bl
Cptimization |

By sequence num SMISC, 6 @

{For "By sequence num", enter sequence
na. in Selection box, See Table 4.xx-3
in Elements Manual for seq. numbers. )

(]34 OJ Apply | Cancel | Help |

— Enter 6 as found in table 3.2 —

— From table 3.2 MMOMZ, SMISC,6,66

ANSYS Example0102 25
Computational Mechanics, AAU, Esbjerg
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Example — Element Table

Element Table Data 1 X

Currently Defined Data and Status:

Latne| Iterm Carmp Tirme Stamp Status

Time= 1.0000 {Current)

ﬁdd...‘J Update | Delete |
Close Help |

Press Add to add the second data line —

ANSYS Example0102
Computational Mechanics, AAU, Esbjerg



Example — Element Table

[i\Define Additional Element Table Items ]

[AYPRIM] Eff MU for BQY sirain I

[ETABLE] Define Additional Element Table Items

Lab Lizer label for item I

Item,Camp Results data item Strain-thermal -
Strain-plastic MNMISC,
Strain-creep L5,
Strain-other LEPEL,
Contact LEFTH, il

Ciptimization (.
By seqUence num SMISCED e

{For "By sequence num"”, enter sequence
no. in Selection box, See Table 4.xx-3
in Elements Manual for seq. numbers.)

Ik .J Apply | Cancel | Help |

— Enter 66 as found in table 3.7 —
— From table 3.7 MMOMz, SMISC,6,66

ANSYS Example0102 27
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ANSYS

Currentlﬁ; Defined Data and Status:

Label Itern Cormp Tirme Stamp Status
SMISA SMIS a] Titme=1.0000 {Current)

Time= 1.0000 {Current)

Add... Update |

Delete |

Close | Heln |

Example Element Table
Element TableData

x|

Example0102
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Example — Plot Line-Element

AMNSYS Main MMenu

AMNSYS Main MMenu

@

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
A Plot Results
Deformed Shap
=ERContour Plot
Nodal Solu
Element Solu
Elem Table
Line Elem Res
vector Plot
Plot Path Item
Concrete Plot
List Results
Query Results
Options for ODutp
Results Yiewer
Write PGR File
Modal Calcs
Element Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Operations
Submodeling
Fatigue
Safety Factor
Define,/Modify
[ .

J

Preferences
Preprocessor
Solution
B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
A Plot Results
Deformed Shape
B Contour Plot
Nodal Solu
Element Solu
Elem Table

-

= ine Elem Res NI

Yector Plot

Plot Path Item

Concrete Plot
List Results
Query Results
Options for ODutp
Results Yiewer
Write PGR File
Modal Calcs
Element Table
Path Operations
Load Case
Check Elem Shape
Write Results
ROM Operations
Submodeling
Fatigue
Safety Factor
Define,/Modify
[ .

J

|

Ef

® oK |

Fact Cptional scale factor

KUND Items to be plotted

Labl Elern table item at node ]

Apply |

li\Plot Line-Element Results

[FLLS] Flot Line-Element Result
Labl Elem table item at node 1

SMISE -
SMISEE -

1l

& Def shape only

x|

-

" Def + undefarmed
" Def + undef edge

Cancel |

Help |

— Press OK

ANSYS

Computational Mechanics, AAU, Esbjerg
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Example — Plot Line-Element

: ANSYS

LINE STRESS
FEE 11 Z004

21:45:40

ITEP=1
3UE =1
TIME=1
S3MIS66

ANSYS Example0102
Computational Mechanics, AAU, Esbjerg
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