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Example — Cantilever beam

|

2

) L
Objective: E = 210000N/mm?®
Compute the maximum deflection v =03
Tasks: L =100mm
Create a table and compare results a=10mm
with results obtained from beam theory? b =10mm
Display the deflection figure? F = 100N

Topics:

Topics: Start of analysis, Element type,

Real constants, Material, modeling, ele-
ment size for beam models, saving/restoring
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Modeling considerations

* As you begin your model generation, you will (consciously or
unconsciously) make a number of decisions that determine how you
will mathematically simulate the physical system:

What are the objectives of your analysis?
Will you model all, or just a portion, of the physical system?
How much detail will you include in your model?

What kinds of elements will you use? How dense should your finite
element mesh be?

* In general, you will attempt to balance computational expense (CPU
time, etc.) against precision of results as you answer these
guestions.

 The decisions you make in the planning stage of your analysis will
largely govern the success or failure of your analysis efforts.

ANSYS
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Modeling considerations

* Linear or Higher Order Elements

 Take Advantage of Symmetry
— The axis of symmetry must coincide with the global Cartesian Y-axis.
— Negative nodal X-coordinates are not permitted.

— The global Cartesian Y-direction represents the axial direction, the
global Cartesian X-direction represents the radial direction, and the
global Cartesian Z-direction corresponds to the circumferential direction.

— Your model should be assembled using appropriate element types:

* For axisymmetric models, use applicable 2-D solids with KEYOPT(3) = 1,
and/or axisymmetric shells. In addition, various link, contact, combination,
and surface elements can be included in a model that also contains
axisymmetric solids or shells. (The program will not realize that these "other"
elements are axisymmetric unless axisymmetric solids or shells are present.)

 How Much Detalil to Include
» Appropriate Mesh Density
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Example - title

Utility Menu > File > Change Jobname e GUI
/jobname, Example0100 Command line entry
| Enter: Example0100

[/FILM&M] Enter new jobname Ihle ° |

Mew log and error files? [~ Mo

Ok, | Cancel | Helpn |

Utility Menu > File > Change Title Enter: Cantilever beam
ftitle, Cantilever beam
X
[/TITLE] Erter new title || °
0] Cancel Help
ANSYS Example0100 5
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Note: An empty #

Example - Keypoints

Preprocessor > Modeling > Create > Keypoints > In Active CS mpering.

/PREPY . # Keypoint number
Ky, General format:  x keynoint x-coordinate
K..100 K#,X,Y,Z Y Keypoint y-coordinate
B Z Keypoint z-coordinate
I\ Create Keypoints in Active Coordinate System x|
[K] Create Keypaints in Active Coordinate System
NPT  Keypoint number l— Press Apply

¥,¥,Z Location in active CS | |

0] | fYalal | [ Earee Hed

>l Enter 100 and

[K] Create Keypaints in Active Coordinate System PreSS Ap p |y
NPT  Keypoint number I
¥,¥,Z Location in active CS | - '

Note: An empty box
result in a zero. It is

OK n&- | . CGI Il_l:I HEIH
4| &I —_— — | allowed to enter 0.0

in each box.
ANSYS Example0100 6
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Example - Numbering

Utility Menu > PlotCtrls > Numbering Switch on Keypoint numbers
Fan Zoom RFotate ...
View Settings ’ Fi\Plot Numbering Controls %]
Mumbering ... [/FMUM] Flot Murmbering Controls
Symbols ... KP  Keypaoint numbers [~ off
Style ?
LIME Line numbers
Fomt Contrals » L
YWindow Controls ¢ AREA Area numbers [T Off
Erase Options >
YOLU Yolume numbers [ off

Animate 4
Annotation 4 MWODE Mode numbers I~ off
Device Options ... Elem / attrib numbering Mo numbering j

i 3
RECECt e TABN Table Mames [ off
Hard Copy ?
save Plot Cirls . SWAL Murmeric contour values [ off
R ar [MUM] Murnbering show with |colors & rurmbers ~|
Reset Plot Cirls

2
Capture Image ... [/REFLOT] Replot upon Ok fapply: IREpl':'t LI
Festore Image ...
Write Metafile s (]34 Q_I Apply | Cancel l Help |
Multi-Plot Contrals .. PI‘eSS OK
ML lt-vindowr Layout ...
I GEsillsllyuoge - Example0100 7
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Example - Lines

Preprocessor > Modeling > Create > Lines > Lines > Straight Line
Create a line between Keypoint KP1 and Keypoint KP2.

L,1,2
Create Straig HINT: By clicking with the right-
® pick Unpick hand mouse button you shift
@ single £ Box between the Pick/Unpick
P function. This is indicated by
. the direction of the cursor
Maximm = 2 arrow:
B
ReyP Ho. - Pick: upward arrow
Fo Unpick: downward arrow
{" Min, Max, Inc
Press OK or Cancel
to finish selection
IE @ Epprty
Deset Cancel@®
Piglk ALl Heln
ANSYS Example0100
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Example - Plot

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help

Replot |

Keypoints b Keypoints

Lines ¢ Hard Points

Areas

volumes Plot Keypoints and Lines
Specified Entities 4

MNodes
Elements
Layered Elements ...

Materials
Data Tables
Array Parameters L.,

Results +
mLlti-Plots
Components 4
Parts
ANSYS Example0100
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Example - List

File Select List Plot PlotCirls  WorkPlane Parameters Macro  MenuCirls  Help

Files »
Status »
Keypoint ¢
i °
Lines ...
Aress _ _ .
volumes — List Keypoints and Lines
Modes ...
Elements 4
Components
Paree .
Picked Entities +
Properties +
Loads 4
Results 4
Oither »
ANSYS Example0100
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Example — Element Type

Preprocessor > Element Type > Add/Edit/Delete

x|
Defined Element Types: ml‘lbrar? of Element Types x|
Library of Element Types SR UEHIEa MSes
Lirk plastic 23
tapered 54
Fipe 30 finite strain
Rigid 2 node 188 -
Solid
Shell ;I 2D elastic 3

Element type reference number I 1
04 | Aoy | Cancel | Help |

Add... |e Sptions- Selete Press Add
Clase | Help |
ANSYS Example0100 11
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Example -

Element Type

Preprocessor > Element Type > Add/Edit/Delete

Element Types .

Defined Element Types:

x|

Add... Options... |0 Belete

IBEAMS element type options ]

Cptions for BEAMS, Element Type Ref, Mo, 1

Member force + mament output K&

Output at extra intermed pts K9 IN.;. inter med pts j

Load offset in terms of K10

Ik |

ILengﬂﬂ Lnits j

Cancel | Help |0

Press Options

Close |

Press Help to learn more about the

ANSYS
Computational Mechanics, AAU, Esbjerg
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Example — Real Constants

Preprocessor > Real Constants > Add

Real Constants l

Defined Feal Constant Sets

MOME DEFIMED

X

Type 1

Add... @

=1L
L | | R

trelete |

Close |

Help |

ANSYS

84

Element Type for Real Col

Choose element type:

Place the cursor
on the relevant
element and
press OK

[ L= =]

Example0100
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Example - Real Constants

Preprocessor > Real Constants > Add

| x
fAVReal Constants for BEAM3 | X| F NN SN
Element Type Reference Mo. 1
Real Constant Set Mo,
Cross-sectional area ARES o——1 Enter 100
Area rmoment of inertia IZ8 o— Enter‘ 8333
Total beam height HEIGHT o—— Enter 10
Shear deflection constant SHEARZE
Initial strain ISTRM
Added massfunit length  ADDMAS
® [k Apply Cancel Help | Edit. . | Delete |
Press Close = ecpe | Hep |
to finish
Press OK
ANSYS Example0100 14
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Example - Material Properties

Preprocessor > Material Props > Material Models
I\Define Material Model Behavior

wWaterial  Edit Help

— Material Models Defined

o]

Double Click
to step in the

— Material Models Available mate”al tree
& Material Model Nurmber 1 ] ﬁ Structural =]
@ Linear
8 Elastic
@ [sofropicll g
€ Orthotropic
@ anisotro [T, Isotropic Properties for Material N X|
Monlinear
© Density Linear Isofropic Material Properties for Material Murmber 1
Thermal Expansior
€ Damping -
| 8 Friction Coefficient
= ] | Temperatures I
femn | e BA=dmwri= ] Teie
‘ ILI_‘ | EX
PR
Add Temperature | Delete Temperature Graph
k. Cancel Help
ANSYS Example0100 15
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Example - Material Properties

Preprocessor > Material Props > Material Models

Click here
Linear Isotropic Properties for Material [ x| Enter 210000 |
Modulus of elasticity to Close
Linear Isotropic Material Properties for Material Mumber 1
Enter 0.3
S S Poisson’s ratio
Temperatures
EX
PRXY ] 0| x|
Material Edit Help
— Material Madels Defined — Material Madels Available
& Material Model Nurnber 1 izl @8 Structural =]
add Temperature | Delete Temperature | & Linear Isotropic &8 Linear
8 Elastic
® Ok | Cani
€ Orthotropic
& Anisofrapic
Monlinear |
& Density
Thermal Expansion Coef
# Darmping
PI’ESS OK - = @ Friction Coefficient
= (e | e B = im] Cumieane B
‘ Iﬂ_‘ J 2]
ANSYS Example0100
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Example — Mesh size

Preprocessor > Meshing > Size Cntrls > ManualSize > Lines > Picked Lines

Element Size

{* pick - Tnpick

v Single {~ Box

" Polygon " Circle

- Loop

Count = 0
Maximum = 1
Minjmum = 1
Line Mo. =

{¥ List of Items

- Min, Max, Inc

0K Apply
Beset Cancel
—@® Pick &l11 Help
— Select Pick All
ANSYS

[i\Element Sizes on Picked Lines ' |

[LESIZE] Element sizes on picked lines

SIZE  Element edge length

MDY Mo, of element divisions

{

(NDIY is used only if SIZE is blank or zero)
ENMOIY SIZE,MNDIY can be changed V¥ ‘es

SPACE Spacing ratio

|

— AMNGSIZ Division arc {degrees)

{ use AMGSIZ only if number of divisions (NOIVY and
element edge length (SIZE) are blank or zero)

Clear attached areas and volumes [ Mo

_0 4 | Ay | Cancel | Help |

Press OK

Example0100

Computational Mechanics, AAU, Esbjerg
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Example - Meshing

Preprocessor > Meshing > Mesh > Lines

% tick @

g e P
L2 UIIEITE

[ Single {" Box ‘

" Polygon {" Circle

o Select individual lines to be meshed by Picking

Count = I

Maximam

Minimam

Line Ho.

NB: It is often necessary to “Clear” the model for
R example if Element Type is to be changed

- Min, Max, Inc

Select all lines defined to be meshed

OE Lpply
Beset Cencel
Bick 211 Help
[ )
ANSYS
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Example — Analysis Type

Solution > Analysis Type > New Analysis

[\\New Analysis ' %]

[ANTYPE] Type of analysis

oK @

" Modal

" Harmonic

" Transient

" Spectrum

" Eigen Buckling
" Substructuring

Cancel | Help |

ANSYS

— Press OK

Example0100
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Displacement > On Keypoints

Select keypoint KP1

¥ pick &— Trpick

Select All DOF to fix/clamp the beam
v Single {" Box

(" Polygen [ Cirels i\ Apply U,ROT on KPs X

£ Leoe [DK] Apply Displacements (U,ROT) on Keypoints

e Notice number Lab2 DOFs to be constrained

Maximum = 2

Minimam = 1

FeyP Ho. = [ 2

{* List of Items Apply as ICnnstant value j

If Constant value then:

VALUE Displacement value I

i Min, Max, Inc

| KEXPND Expand disp to nodes? I~ Ho
R :‘applx oK .J Apply | Cancel | Help |
Heset Cancel
Pick A1l Hel
= — Press OK
ANSYS Example0100 20
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Example — Define Loads

Solution > Define Loads > Apply > Structural > Force/Moment > On Keypoints

Apply F/M on

@ pick @—Ftrptor—

v 5 ingle { Box

" Polygon { Circle
[ Loop

Count = 0
Maximum = 2
Minimum = 1
EeyP Ho. = @&

Notice number

{¥ List of Items

- Min, Max, Inc

Select keypoint KP2

Change to FY

I Apply F/M on KPs x|
[Fk] Apply ForceMoment on Keypoints
Lab  Direction of force/morm P Iw T|

Apply as ICDnatant valLe j

CE @ Eppty
Feset Cancel
Pick A11 Help
ANSYS

Computational Mechanics, AAU, Esbjerg

If Constant value then:

YALUE  Forcefmoment value I [

0] Tl dpphy Cancel |

Press OK to finish Enter -100

Help |

Example0100 21



Example - Save

Display of Analysis model

AMSYS Toolhar

Save the model
[ SavE_DB | RESLIM_DB ‘ QUIT | F'DWRGRF'HI E-CAE |

I

ANSYS Example0100 22
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Example — Write DB log file

File > Write DB log file
Enter “example0100.Igw”

Write Database Log

“wWiite Databasze Log o Directaries:

b hadminiztrator

_I Cancel |

E' DEIEUMENTS .-’-'-.N
= ADMINISTRATO ﬂl

3 Cockies
o | Brar o
Lizt Filez of Tupe: Dirives:
IDataI:uase Log (% lgw) LI I Ho LI Metwork. .. |
I'W'rite non-essential cmds as comments LI
ANSYS Example0100
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Example — Solve LS

Solution > Solve > Current LS

ANSYS Main Menu @

Preferences

Preprocessor

B Solution
Analysis Type

el Solve Current LoadStep X
il Siteg OGS Solve Current Load Step | x|

= rrE"t 5 o [SOLVE] Begin Solution of Current Load Step

From LS Files

Partial Solu Review the summary information in the lister window (entitled
Adaptive Mesh "/STATUS Command"), then press OK to start the solution.
FSI Set Up

ADAMS Connection
Unabridged Menu | e T
General Postproc Ok, Cancel Help
TimeHist Postpro

Topological Opt
ROM Tool
Design Opt
Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

HEREEEHEEBEA

Press OK

o Example0100
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Example — Solution Status

\i‘) Solution is done!

Press Close

Press here
to Close
‘
I\ /STATUS Command i |
File
SOLUTIOH OPTIONS
PROBLEH DIHEWSIOWALITY. . . . . . . . . . . .. 2-0
DEGREES OF FREEDOH. . . . . . U Uy ROTE
AHALYSIS TWFE . . . . . o o s e e e STHTIC (STEADY-STHTE)
LOAD STEP OPTIOHS
LOAD STEP HUMBER. . . . . . . . . . . v o . .. 1
TIHE AT EWD OF THE LOAD STEF. . . . . ... .. 1.0000
HUHBER OF SUBSTEPS. . . . . . . . . . o o . .. 1
STEP CHAWGE EOUWDARY COWDITIONS . . . . . . .. HO
PEINT QUTPUT COMTROLS . . . . . . . . & . . .. HO PRINTOUT
DATABASE OUTPUT COWTROLS. . . . . & o & o v . ALL DATA HRITTEW
FOR THE LAST SUBSTEP
ANSYS Example0100 25
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Example - PostProcessing

General Postproc > Plot Results > Deformed Shape

Plot Deformed Shape | x|

[FLDISF] Flot Deformed Shape
KUND  Items to be plotted

" Def + undeformed @

" Def + undef edge

oK | Apply Cancel | Help |

Select “Def+undeformed”
and Press OK

ANSYS Example0100 26
Computational Mechanics, AAU, Esbjerg



Example - PostProcessing

1 R
DISPLACEMENT ANSYS

STEP=1
SUE =1
TIME=1
DME =.193501

The scaling of
displacement
can be
adjusted by

— Read Maximum displacement: DMX

Utility Menu> PlotCtrls> Style> Displacement Scaling

ANSYS Example0100 27
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/

Example — Clear & Start New

Clear & Start Mew ...
iChange Jobname ...
Change Directory ...
iChange Title ...

File Select List Plot PlotCirls \WorkPlane Parameters Macro MenuCirls  Help

Fesume Jobname.db ...

Fesume fram ...

Save as Jobname.db
Save as ...
Write DB log file ...

Read Input from ...
Switch Cutput to

List
File Cperations

ANSYS File Options ...

Import
Export ...

Feport Generatar ...

Exit ...

S .
You can include commands to be

executed when the program starts up in ——
the start71.ans file.

fi\Clear Database and Start New X|

[/CLEAR] Clear database and start new!
Read start. ans after clear?

" Do not read file

Ok | Cancel | Help |

Clears (zeros out) the database stored in
memory. Clearing the database has the same
effect as leaving and reentering the ANSYS
program, but does not require you to exit.

Example0100 28
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Example — Comments/Questions

 Why is It relevant to consider a Beam
model In many cases?

 The “example0100.lgw” can be edited In
“Notepad”

e What are the assumptions in beam
theory?

 Will the number of elements affect the
solution?

ANSYS Example0100
Computational Mechanics, AAU, Esbjerg
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